aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/package-ipkg.mk2
-rw-r--r--package/base-files/Makefile4
2 files changed, 3 insertions, 3 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 442d3854f0..c4c8f4a36f 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -207,7 +207,7 @@ $(_endef)
(cd $$(IDIR_$(1)); \
( \
find . -type f \! -path ./CONTROL/\* -exec sha256sum \{\} \; 2> /dev/null | \
- sed 's|\([[:blank:]]\)\./|\1/|' > $$(IDIR_$(1))/CONTROL/files-sha256 \
+ sed 's|\([[:blank:]]\)\./|\1/|' > $$(IDIR_$(1))/CONTROL/files-sha256sum \
) || true \
)
endif
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 35ad80888f..268d7d4cc9 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -204,8 +204,8 @@ define Package/base-files/install
mkdir -p $(1)/etc/opkg; \
$(call FeedSourcesAppend,$(1)/etc/opkg/distfeeds.conf); \
$(VERSION_SED_SCRIPT) $(1)/etc/opkg/distfeeds.conf)
- $(if $(CONFIG_IPK_FILES_CHECKSUMS), \
- rm -f $(1)/sbin/pkg_check,)
+ $(if $(CONFIG_IPK_FILES_CHECKSUMS),, \
+ rm -f $(1)/sbin/pkg_check)
endef
ifneq ($(DUMP),1)