aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/network/config/gre/Makefile2
-rwxr-xr-xpackage/network/config/gre/files/gre.sh6
2 files changed, 5 insertions, 3 deletions
diff --git a/package/network/config/gre/Makefile b/package/network/config/gre/Makefile
index e3a79e11e4..ca19f5d47c 100644
--- a/package/network/config/gre/Makefile
+++ b/package/network/config/gre/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gre
PKG_VERSION:=1
-PKG_RELEASE:=11
+PKG_RELEASE:=12
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/config/gre/files/gre.sh b/package/network/config/gre/files/gre.sh
index 3414ed3047..eb3df5b48c 100755
--- a/package/network/config/gre/files/gre.sh
+++ b/package/network/config/gre/files/gre.sh
@@ -13,8 +13,8 @@ gre_generic_setup() {
local local="$3"
local remote="$4"
local link="$5"
- local mtu ttl tos zone ikey okey icsum ocsum iseqno oseqno multicast
- json_get_vars mtu ttl tos zone ikey okey icsum ocsum iseqno oseqno multicast
+ local mtu ipv6 ttl tos zone ikey okey icsum ocsum iseqno oseqno multicast
+ json_get_vars mtu ipv6 ttl tos zone ikey okey icsum ocsum iseqno oseqno multicast
[ -z "$multicast" ] && multicast=1
@@ -23,6 +23,7 @@ gre_generic_setup() {
proto_add_tunnel
json_add_string mode "$mode"
json_add_int mtu "${mtu:-1280}"
+ json_add_boolean ipv6 "${ipv6:-1}"
[ -n "$df" ] && json_add_boolean df "$df"
[ -n "$ttl" ] && json_add_int ttl "$ttl"
[ -n "$tos" ] && json_add_string tos "$tos"
@@ -248,6 +249,7 @@ gre_generic_init_config() {
available=1
proto_config_add_int "mtu"
+ proto_config_add_boolean "ipv6"
proto_config_add_int "ttl"
proto_config_add_string "tos"
proto_config_add_string "tunlink"