aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/netdevices.mk18
-rw-r--r--target/linux/imx6/config-4.41
-rw-r--r--target/linux/imx6/image/Makefile2
3 files changed, 2 insertions, 19 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 8be6453090..18370ddcc8 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -130,24 +130,6 @@ endef
$(eval $(call KernelPackage,et131x))
-define KernelPackage/gw16083
- SUBMENU:=$(NETWORK_DEVICES_MENU)
- TITLE:=Gateworks Ventana Ethernet Expansion Mezzanine driver
- URL:=http://www.gateworks.com
- FILES:=$(LINUX_DIR)/drivers/net/phy/gw16083.ko
- KCONFIG:=CONFIG_GATEWORKS_GW16083
- DEPENDS:=@TARGET_imx6 @PCI_SUPPORT +kmod-libphy +kmod-igb
- AUTOLOAD:=$(call AutoLoad,36,gw16083)
-endef
-
-define KernelPackage/gw16083/description
- This package contains the gw16083 kernel module for supporting the Gateworks
- Ventana Ethernet Expansion Mezzanine.
-endef
-
-$(eval $(call KernelPackage,gw16083))
-
-
define KernelPackage/phylib-broadcom
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Broadcom Ethernet PHY library
diff --git a/target/linux/imx6/config-4.4 b/target/linux/imx6/config-4.4
index 44c0e99f3a..353ca2e6d8 100644
--- a/target/linux/imx6/config-4.4
+++ b/target/linux/imx6/config-4.4
@@ -144,6 +144,7 @@ CONFIG_FS_MBCACHE=y
CONFIG_FS_POSIX_ACL=y
CONFIG_FTRACE=y
# CONFIG_FTRACE_SYSCALLS is not set
+CONFIG_GATEWORKS_GW16083=y
CONFIG_GENERIC_ALLOCATOR=y
CONFIG_GENERIC_BUG=y
CONFIG_GENERIC_CLOCKEVENTS=y
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 2c17058250..2e4763ea65 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -90,7 +90,7 @@ define Device/ventana
kmod-sound-core kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
kmod-can kmod-can-flexcan kmod-can-raw \
kmod-hwmon-gsc \
- kmod-leds-gpio kmod-pps-gpio kmod-gw16083 \
+ kmod-leds-gpio kmod-pps-gpio \
kobs-ng
KERNEL += | boot-overlay
IMAGES := nand.ubi bootfs.tar.gz