aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/firmware/amd64-microcode/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/package/firmware/amd64-microcode/Makefile b/package/firmware/amd64-microcode/Makefile
index adf3352af2..4fd3d04610 100644
--- a/package/firmware/amd64-microcode/Makefile
+++ b/package/firmware/amd64-microcode/Makefile
@@ -35,17 +35,11 @@ define Build/Prepare
endef
define Build/Compile
- mkdir -p $(PKG_BUILD_DIR)/kernel/x86/microcode/
- cat $(PKG_BUILD_DIR)/microcode_amd*.bin \
- > $(PKG_BUILD_DIR)/kernel/x86/microcode/AuthenticAMD.bin
- (cd $(PKG_BUILD_DIR); \
- echo "kernel/x86/microcode/AuthenticAMD.bin" \
- | cpio -o -H newc --reproducible > amd-ucode.cpio)
endef
define Package/amd64-microcode/install
- $(INSTALL_DIR) $(1)/boot
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/amd-ucode.cpio $(1)/boot/amd-ucode.img
+ $(INSTALL_DIR) $(1)/lib/firmware/amd-ucode
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/*.bin $(1)/lib/firmware/amd-ucode
endef
$(eval $(call BuildPackage,amd64-microcode))