aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/lib.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/lib.mk b/package/kernel/linux/modules/lib.mk
index ea29d08b55..e14c6b31c0 100644
--- a/package/kernel/linux/modules/lib.mk
+++ b/package/kernel/linux/modules/lib.mk
@@ -187,10 +187,10 @@ define KernelPackage/lib-xor
TITLE:=XOR blocks algorithm support
HIDDEN:=1
KCONFIG:=CONFIG_XOR_BLOCKS
-ifneq ($(wildcard $(LINUX_DIR)/arch/arm/lib/xor-neon.ko),)
+ifneq ($(wildcard $(LINUX_DIR)/arch/$(LINUX_KARCH)/lib/xor-neon.ko),)
FILES:= \
$(LINUX_DIR)/crypto/xor.ko \
- $(LINUX_DIR)/arch/arm/lib/xor-neon.ko
+ $(LINUX_DIR)/arch/$(LINUX_KARCH)/lib/xor-neon.ko
AUTOLOAD:=$(call AutoProbe,xor-neon xor)
else
FILES:=$(LINUX_DIR)/crypto/xor.ko