aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/brcm47xx/image/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 84e70051a4..2c79ab0b1a 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -51,10 +51,11 @@ endef
define Build/trx-with-loader
$(STAGING_DIR_HOST)/bin/trx \
-m 33554432 \
- -o $@ \
+ -o $@.new \
-f $(KDIR)/loader.gz \
-f $(IMAGE_KERNEL) \
$(call trxalign/$(FILESYSTEM),$(FILESYSTEM))
+ mv $@.new $@
endef
define Build/trx-v2-with-loader
@@ -71,9 +72,10 @@ endef
define Build/trx-without-loader
$(STAGING_DIR_HOST)/bin/trx \
-m 33554432 \
- -o $@ \
+ -o $@.new \
-f $(IMAGE_KERNEL) \
$(call trxalign/$(FILESYSTEM),$(FILESYSTEM))
+ mv $@.new $@
endef
define Build/asus-trx