aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/omap/Makefile2
-rw-r--r--target/linux/omap/config-4.145
-rw-r--r--target/linux/omap/config-4.95
3 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/omap/Makefile b/target/linux/omap/Makefile
index fc8e40dee2..f22841e019 100644
--- a/target/linux/omap/Makefile
+++ b/target/linux/omap/Makefile
@@ -26,4 +26,6 @@ endef
include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
+
$(eval $(call BuildTarget))
diff --git a/target/linux/omap/config-4.14 b/target/linux/omap/config-4.14
index 7c60947e30..a94e127a44 100644
--- a/target/linux/omap/config-4.14
+++ b/target/linux/omap/config-4.14
@@ -232,6 +232,11 @@ CONFIG_EXTCON=y
CONFIG_EXTCON_PALMAS=y
CONFIG_EXTCON_USB_GPIO=y
CONFIG_FANOTIFY=y
+# CONFIG_F2FS_CHECK_FS is not set
+CONFIG_F2FS_FS=y
+# CONFIG_F2FS_FS_SECURITY is not set
+CONFIG_F2FS_FS_XATTR=y
+CONFIG_F2FS_STAT_FS=y
CONFIG_FAT_FS=y
CONFIG_FB_CMDLINE=y
CONFIG_FHANDLE=y
diff --git a/target/linux/omap/config-4.9 b/target/linux/omap/config-4.9
index 4272c2f90f..9cd4084308 100644
--- a/target/linux/omap/config-4.9
+++ b/target/linux/omap/config-4.9
@@ -229,6 +229,11 @@ CONFIG_EXTCON=y
CONFIG_EXTCON_PALMAS=y
CONFIG_EXTCON_USB_GPIO=y
CONFIG_FANOTIFY=y
+# CONFIG_F2FS_CHECK_FS is not set
+CONFIG_F2FS_FS=y
+# CONFIG_F2FS_FS_SECURITY is not set
+CONFIG_F2FS_FS_XATTR=y
+CONFIG_F2FS_STAT_FS=y
CONFIG_FAT_FS=y
CONFIG_FB_CMDLINE=y
CONFIG_FHANDLE=y