aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--toolchain/gcc/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index f7390c159e..e2dfcea6cb 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -85,7 +85,7 @@ endif
GCC_CONFIGURE:= \
SHELL="$(BASH)" \
- $(if $(shell gcc --version 2>&1 | grep LLVM), \
+ $(if $(shell gcc --version 2>&1 | grep -E "Apple.(LLVM|clang)"), \
CFLAGS="-O2 -fbracket-depth=512 -pipe" \
CXXFLAGS="-O2 -fbracket-depth=512 -pipe" \
) \