aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/01_leds1
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh1
-rw-r--r--target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata1
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/config-4.41
-rw-r--r--target/linux/ar71xx/config-4.91
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt10
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-re450.c62
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
-rw-r--r--target/linux/ar71xx/generic/config-default1
-rw-r--r--target/linux/ar71xx/image/generic-tp-link.mk19
-rw-r--r--tools/firmware-utils/src/tplink-safeloader.c43
15 files changed, 142 insertions, 5 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/01_leds b/target/linux/ar71xx/base-files/etc/board.d/01_leds
index a3154db7ed..c45376f9e4 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/01_leds
+++ b/target/linux/ar71xx/base-files/etc/board.d/01_leds
@@ -616,6 +616,7 @@ rb-wap-2nd)
ucidef_set_led_timer "user" "USER" "rb:green:user" "1000" "1000"
ucidef_set_led_wlan "wlan" "WLAN" "rb:green:wlan" "phy0tpt"
;;
+re355|\
re450)
ucidef_set_led_netdev "lan_data" "LAN Data" "$board:green:lan_data" "eth0" "tx rx"
ucidef_set_led_netdev "lan_link" "LAN Link" "$board:green:lan_link" "eth0" "link"
diff --git a/target/linux/ar71xx/base-files/etc/board.d/02_network b/target/linux/ar71xx/base-files/etc/board.d/02_network
index 435d413c63..b208f38b5e 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/02_network
+++ b/target/linux/ar71xx/base-files/etc/board.d/02_network
@@ -107,6 +107,7 @@ ar71xx_setup_interfaces()
rb-sxt5n|\
rb-wap-2nd|\
rb-wapg-5hact2hnd|\
+ re355|\
re450|\
rocket-m-xw|\
sc300m |\
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index 2e9fd1d637..3b5fc32298 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -359,6 +359,7 @@ get_status_led() {
rb-sxt5n)
status_led="rb:green:power"
;;
+ re355|\
re450|\
sc300m)
status_led="$board:blue:power"
diff --git a/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index ca90563d25..8284550e92 100644
--- a/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -106,6 +106,7 @@ case "$FIRMWARE" in
rb-wapg-5hact2hnd)
ath10kcal_from_file "/sys/firmware/routerboot/ext_wlan_data" 20480 2116
;;
+ re355|\
re450|\
tl-wr902ac-v1)
ath10kcal_extract "art" 20480 2116
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 267c575545..7c7a0e2674 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -871,6 +871,9 @@ ar71xx_board_detect() {
*"Rambutan"*)
name="rambutan"
;;
+ *"RE355")
+ name="re355"
+ ;;
*"RE450")
name="re450"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 21e387389d..946a886071 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -390,6 +390,7 @@ platform_check_image() {
omy-x1|\
onion-omega|\
oolite|\
+ re355|\
re450|\
rut900|\
smart-300|\
diff --git a/target/linux/ar71xx/config-4.4 b/target/linux/ar71xx/config-4.4
index a952476f18..447ab01dae 100644
--- a/target/linux/ar71xx/config-4.4
+++ b/target/linux/ar71xx/config-4.4
@@ -168,6 +168,7 @@ CONFIG_ATH79=y
# CONFIG_ATH79_MACH_RB95X is not set
# CONFIG_ATH79_MACH_RBSPI is not set
# CONFIG_ATH79_MACH_RBSXTLITE is not set
+# CONFIG_ATH79_MACH_RE355 is not set
# CONFIG_ATH79_MACH_RE450 is not set
# CONFIG_ATH79_MACH_RUT9XX is not set
# CONFIG_ATH79_MACH_RW2458N is not set
diff --git a/target/linux/ar71xx/config-4.9 b/target/linux/ar71xx/config-4.9
index d0cfa462bf..e5fce99b19 100644
--- a/target/linux/ar71xx/config-4.9
+++ b/target/linux/ar71xx/config-4.9
@@ -166,6 +166,7 @@ CONFIG_ATH79=y
# CONFIG_ATH79_MACH_RB95X is not set
# CONFIG_ATH79_MACH_RBSPI is not set
# CONFIG_ATH79_MACH_RBSXTLITE is not set
+# CONFIG_ATH79_MACH_RE355 is not set
# CONFIG_ATH79_MACH_RE450 is not set
# CONFIG_ATH79_MACH_RUT9XX is not set
# CONFIG_ATH79_MACH_RW2458N is not set
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 20eb210105..eda1e4002b 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -1305,6 +1305,16 @@ config ATH79_MACH_MZK_W300NH
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
+config ATH79_MACH_RE355
+ bool "TP-LINK RE355 board support"
+ select SOC_QCA955X
+ select ATH79_DEV_AP9X_PCI if PCI
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_RE450
bool "TP-LINK RE450 board support"
select SOC_QCA955X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 9be721ac20..27ef57d167 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -177,6 +177,7 @@ obj-$(CONFIG_ATH79_MACH_RB941) += mach-rb941.o
obj-$(CONFIG_ATH79_MACH_RB95X) += mach-rb95x.o
obj-$(CONFIG_ATH79_MACH_RBSPI) += mach-rbspi.o
obj-$(CONFIG_ATH79_MACH_RBSXTLITE) += mach-rbsxtlite.o
+obj-$(CONFIG_ATH79_MACH_RE355) += mach-re450.o
obj-$(CONFIG_ATH79_MACH_RE450) += mach-re450.o
obj-$(CONFIG_ATH79_MACH_RUT9XX) += mach-rut9xx.o
obj-$(CONFIG_ATH79_MACH_RW2458N) += mach-rw2458n.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-re450.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-re450.c
index 25de6e729f..991aa1c9a9 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/mach-re450.c
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-re450.c
@@ -1,9 +1,10 @@
/*
- * TP-LINK Archer RE450 board support
+ * TP-LINK RE355/RE450 board support
*
* Copyright (c) 2013 Gabor Juhos <juhosg@openwrt.org>
* Copyright (c) 2016 Tal Keren <kooolk@gmail.com>
- *
+ * Copyright (c) 2018 Henryk Heisig <hyniu@o2.pl>
+ *
* Based on the Qualcomm Atheros AP135/AP136 reference board support code
* Copyright (c) 2012 Qualcomm Atheros
*
@@ -72,6 +73,42 @@ static struct flash_platform_data tl_re450_flash_data = {
.part_probes = tl_re450_part_probes,
};
+static struct gpio_led re355_leds_gpio[] __initdata = {
+ {
+ .name = "re355:blue:power",
+ .gpio = RE450_GPIO_LED_SYSTEM,
+ .active_low = 1,
+ },
+ {
+ .name = "re355:blue:wlan2g",
+ .gpio = RE450_GPIO_LED_WLAN2G,
+ .active_low = 1,
+ },
+ {
+ .name = "re355:blue:wlan5g",
+ .gpio = RE450_GPIO_LED_WLAN5G,
+ .active_low = 1,
+ },
+ {
+ .name = "re355:blue:wps",
+ .gpio = RE450_GPIO_LED_JUMPSTART,
+ },
+ {
+ .name = "re355:red:wps",
+ .gpio = RE450_GPIO_LED_JUMPSTART_RED,
+ },
+ {
+ .name = "re355:green:lan_data",
+ .gpio = RE450_GPIO_LED_LAN_DATA,
+ .active_low = 1,
+ },
+ {
+ .name = "re355:green:lan_link",
+ .gpio = RE450_GPIO_LED_LAN_LINK,
+ .active_low = 1,
+ },
+};
+
static struct gpio_led re450_leds_gpio[] __initdata = {
{
.name = "re450:blue:power",
@@ -149,15 +186,13 @@ static struct platform_device re450_phy_device = {
},
};
-static void __init re450_setup(void)
+static void __init rex5x_setup(void)
{
u8 *mac = (u8 *) KSEG1ADDR(0x1f610008);
u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
u8 tmpmac[ETH_ALEN];
ath79_register_m25p80(&tl_re450_flash_data);
- ath79_register_leds_gpio(-1, ARRAY_SIZE(re450_leds_gpio),
- re450_leds_gpio);
ath79_register_gpio_keys_polled(-1, RE450_KEYS_POLL_INTERVAL,
ARRAY_SIZE(re450_gpio_keys),
re450_gpio_keys);
@@ -183,5 +218,22 @@ static void __init re450_setup(void)
ath79_register_eth(0);
}
+static void __init re355_setup(void)
+{
+ rex5x_setup();
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(re355_leds_gpio),
+ re355_leds_gpio);
+}
+
+MIPS_MACHINE(ATH79_MACH_RE355, "RE355", "TP-LINK RE355",
+ re355_setup)
+
+static void __init re450_setup(void)
+{
+ rex5x_setup();
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(re450_leds_gpio),
+ re450_leds_gpio);
+}
+
MIPS_MACHINE(ATH79_MACH_RE450, "RE450", "TP-LINK RE450",
re450_setup)
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index 7434f340af..27269e54d6 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -207,6 +207,7 @@ enum ath79_mach_type {
ATH79_MACH_RB_WAPAC, /* Mikrotik RouterBOARD wAPG-5HacT2HnD */
ATH79_MACH_RB_SXTLITE2ND, /* Mikrotik RouterBOARD SXT Lite 2nD */
ATH79_MACH_RB_SXTLITE5ND, /* Mikrotik RouterBOARD SXT Lite 5nD */
+ ATH79_MACH_RE355, /* TP-LINK RE355 */
ATH79_MACH_RE450, /* TP-LINK RE450 */
ATH79_MACH_RUT9XX, /* Teltonika RUT900 series */
ATH79_MACH_RW2458N, /* Redwave RW2458N */
diff --git a/target/linux/ar71xx/generic/config-default b/target/linux/ar71xx/generic/config-default
index 42df64d780..892d33dc8c 100644
--- a/target/linux/ar71xx/generic/config-default
+++ b/target/linux/ar71xx/generic/config-default
@@ -125,6 +125,7 @@ CONFIG_ATH79_MACH_PQI_AIR_PEN=y
CONFIG_ATH79_MACH_QIHOO_C301=y
CONFIG_ATH79_MACH_R36A=y
CONFIG_ATH79_MACH_R602N=y
+CONFIG_ATH79_MACH_RE355=y
CONFIG_ATH79_MACH_RE450=y
CONFIG_ATH79_MACH_RUT9XX=y
CONFIG_ATH79_MACH_RW2458N=y
diff --git a/target/linux/ar71xx/image/generic-tp-link.mk b/target/linux/ar71xx/image/generic-tp-link.mk
index b0d99e2599..48eed6b15b 100644
--- a/target/linux/ar71xx/image/generic-tp-link.mk
+++ b/target/linux/ar71xx/image/generic-tp-link.mk
@@ -184,6 +184,25 @@ define Device/eap120-v1
endef
TARGET_DEVICES += eap120-v1
+define Device/re355-v1
+ DEVICE_TITLE := TP-LINK RE355 v1
+ DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x
+ MTDPARTS := spi0.0:128k(u-boot)ro,6016k(firmware),64k(partition-table)ro,64k(product-info)ro,1856k(config)ro,64k(art)ro
+ IMAGE_SIZE := 7936k
+ BOARDNAME := RE355
+ TPLINK_BOARD_ID := RE355
+ DEVICE_PROFILE := RE355
+ LOADER_TYPE := elf
+ TPLINK_HWID := 0x0
+ TPLINK_HWREV := 0
+ TPLINK_HEADER_VERSION := 1
+ KERNEL := kernel-bin | patch-cmdline | lzma | tplink-v1-header
+ IMAGES := sysupgrade.bin factory.bin
+ IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade
+ IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
+endef
+TARGET_DEVICES += re355-v1
+
define Device/re450-v1
DEVICE_TITLE := TP-LINK RE450 v1
DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x
diff --git a/tools/firmware-utils/src/tplink-safeloader.c b/tools/firmware-utils/src/tplink-safeloader.c
index 88e2e88bdf..c96edb4609 100644
--- a/tools/firmware-utils/src/tplink-safeloader.c
+++ b/tools/firmware-utils/src/tplink-safeloader.c
@@ -871,6 +871,49 @@ static struct device_info boards[] = {
.last_sysupgrade_partition = "file-system"
},
+ /** Firmware layout for the RE355 */
+ {
+ .id = "RE355",
+ .vendor = "",
+ .support_list =
+ "SupportList:\r\n"
+ "{product_name:RE355,product_ver:1.0.0,special_id:00000000}\r\n"
+ "{product_name:RE355,product_ver:1.0.0,special_id:55530000}\r\n"
+ "{product_name:RE355,product_ver:1.0.0,special_id:45550000}\r\n"
+ "{product_name:RE355,product_ver:1.0.0,special_id:4A500000}\r\n"
+ "{product_name:RE355,product_ver:1.0.0,special_id:43410000}\r\n"
+ "{product_name:RE355,product_ver:1.0.0,special_id:41550000}\r\n"
+ "{product_name:RE355,product_ver:1.0.0,special_id:4B520000}\r\n"
+ "{product_name:RE355,product_ver:1.0.0,special_id:55534100}\r\n",
+ .support_trail = '\x00',
+ .soft_ver = NULL,
+
+ /**
+ The flash partition table for RE355;
+ it is almost the same as the one used by the stock images,
+ 576KB were moved from file-system to os-image.
+ */
+ .partitions = {
+ {"fs-uboot", 0x00000, 0x20000},
+ {"os-image", 0x20000, 0x180000},
+ {"file-system", 0x1a0000, 0x460000},
+ {"partition-table", 0x600000, 0x02000},
+ {"default-mac", 0x610000, 0x00020},
+ {"pin", 0x610100, 0x00020},
+ {"product-info", 0x611100, 0x01000},
+ {"soft-version", 0x620000, 0x01000},
+ {"support-list", 0x621000, 0x01000},
+ {"profile", 0x622000, 0x08000},
+ {"user-config", 0x630000, 0x10000},
+ {"default-config", 0x640000, 0x10000},
+ {"radio", 0x7f0000, 0x10000},
+ {NULL, 0, 0}
+ },
+
+ .first_sysupgrade_partition = "os-image",
+ .last_sysupgrade_partition = "file-system"
+ },
+
/** Firmware layout for the RE450 */
{
.id = "RE450",