aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/image-commands.mk5
-rw-r--r--target/linux/brcm63xx/image/Makefile5
2 files changed, 5 insertions, 5 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 5e24c5e3aa..65fa36d2be 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -242,6 +242,11 @@ define Build/pad-offset
mv $@.new $@
endef
+define Build/xor-image
+ $(STAGING_DIR_HOST)/bin/xorimage -i $@ -o $@.xor $(1)
+ mv $@.xor $@
+endef
+
define Build/check-size
@[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -ge "$$(stat -c%s $@)" ] || { \
echo "WARNING: Image file $@ is too big" >&2; \
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 21fc69e24e..1cf64bd8e7 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -132,11 +132,6 @@ define Build/spw303v-bin
mv $@.spw303v $@
endef
-define Build/xor-image
- $(STAGING_DIR_HOST)/bin/xorimage -i $@ -o $@.xor
- mv $@.xor $@
-endef
-
define Build/zyxel-bin
$(STAGING_DIR_HOST)/bin/zyxbcm -i $@ -o $@.zyxel
mv $@.zyxel $@