aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network11
-rw-r--r--target/linux/ath79/dts/ar7242_buffalo_bhr-4grv.dts13
-rw-r--r--target/linux/ath79/image/generic.mk13
3 files changed, 32 insertions, 5 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index 54fbe7b350..e608825fb8 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -27,11 +27,7 @@ ath79_setup_interfaces()
wd,mynet-wifi-rangeextender)
ucidef_set_interface_lan "eth0"
;;
- buffalo,wzr-hp-ag300h)
- ucidef_set_interface_wan "eth1"
- ucidef_add_switch "switch0" \
- "0@eth0" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1"
- ;;
+ buffalo,bhr-4grv|\
buffalo,wzr-hp-g450h)
ucidef_add_switch "switch0" \
"0@eth0" "2:lan" "3:lan" "4:lan" "5:lan" "1:wan"
@@ -40,6 +36,11 @@ ath79_setup_interfaces()
ucidef_add_switch "switch0" \
"0@eth1" "1:lan" "2:lan" "3:lan" "4:lan" "5:wan" "6@eth0"
;;
+ buffalo,wzr-hp-ag300h)
+ ucidef_set_interface_wan "eth1"
+ ucidef_add_switch "switch0" \
+ "0@eth0" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1"
+ ;;
dlink,dir-825-b1)
ucidef_set_interface_wan "eth1"
ucidef_add_switch "switch0" \
diff --git a/target/linux/ath79/dts/ar7242_buffalo_bhr-4grv.dts b/target/linux/ath79/dts/ar7242_buffalo_bhr-4grv.dts
new file mode 100644
index 0000000000..7ce9f6497f
--- /dev/null
+++ b/target/linux/ath79/dts/ar7242_buffalo_bhr-4grv.dts
@@ -0,0 +1,13 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "ar7242_buffalo_wzr-bhr.dtsi"
+
+/ {
+ compatible = "buffalo,bhr-4grv", "qca,ar7242";
+ model = "Buffalo BHR-4GRV";
+};
+
+&sec_vpn {
+ label = "buffalo:orange:vpn";
+};
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 91325cf4d4..39f59524d9 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -69,6 +69,19 @@ define Device/avm_fritz4020
endef
TARGET_DEVICES += avm_fritz4020
+define Device/buffalo_bhr-4grv
+ ATH_SOC := ar7242
+ DEVICE_TITLE := Buffalo BHR-4GRV
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+ IMAGE_SIZE := 32256k
+ IMAGES += factory.bin tftp.bin
+ IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.bin := $$(IMAGE/default) | buffalo-enc BHR-4GRV 1.99 | buffalo-tag BHR-4GRV
+ IMAGE/tftp.bin := $$(IMAGE/default) | buffalo-tftp-header
+ SUPPORTED_DEVICES += wzr-hp-g450h
+endef
+TARGET_DEVICES += buffalo_bhr-4grv
+
define Device/buffalo_wzr-hp-ag300h
ATH_SOC := ar7161
DEVICE_TITLE := Buffalo WZR-HP-AG300H