aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/cns3xxx/patches-4.14/075-spi_support.patch2
-rw-r--r--target/linux/generic/pending-4.14/490-ubi-auto-attach-mtd-device-named-ubi-or-data-on-boot.patch4
-rw-r--r--target/linux/ipq40xx/patches-4.14/400-mtd-ubi-add-quirk-to-autoload-ubi-on-rt-ac58u.patch2
-rw-r--r--target/linux/mediatek/patches-4.14/0006-reset-mediatek-mt2701-reset-driver.patch2
-rw-r--r--target/linux/mediatek/patches-4.14/0064-dts.patch10
6 files changed, 12 insertions, 12 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 9191bddc7d..8d0a62347c 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -5,12 +5,12 @@ LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .71
LINUX_VERSION-4.4 = .121
LINUX_VERSION-4.9 = .96
-LINUX_VERSION-4.14 = .34
+LINUX_VERSION-4.14 = .36
LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
LINUX_KERNEL_HASH-4.4.121 = 44a88268b5088dc326b30c9b9133ac35a9a200b636b7268d08f32abeae6ca729
LINUX_KERNEL_HASH-4.9.96 = 826f596eb5197f8b17304649c2990dd7b766f5c79076cae79f4261c40cea877f
-LINUX_KERNEL_HASH-4.14.34 = 782b6c4c85275c382c820e1934d3e6003ef468f43cfc5e7c22bc07c331a12bb9
+LINUX_KERNEL_HASH-4.14.36 = cae24404d7b5812a331cbbc430b3ab75ca0f76eb16803528cbffbc42e768bc43
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/cns3xxx/patches-4.14/075-spi_support.patch b/target/linux/cns3xxx/patches-4.14/075-spi_support.patch
index 8a51eb396b..e38dbdb75e 100644
--- a/target/linux/cns3xxx/patches-4.14/075-spi_support.patch
+++ b/target/linux/cns3xxx/patches-4.14/075-spi_support.patch
@@ -39,7 +39,7 @@
/**
--- a/drivers/spi/spi.c
+++ b/drivers/spi/spi.c
-@@ -1021,6 +1021,9 @@ static int spi_transfer_one_message(stru
+@@ -1027,6 +1027,9 @@ static int spi_transfer_one_message(stru
list_for_each_entry(xfer, &msg->transfers, transfer_list) {
trace_spi_transfer_start(msg, xfer);
diff --git a/target/linux/generic/pending-4.14/490-ubi-auto-attach-mtd-device-named-ubi-or-data-on-boot.patch b/target/linux/generic/pending-4.14/490-ubi-auto-attach-mtd-device-named-ubi-or-data-on-boot.patch
index 180d1407d2..2a09caf442 100644
--- a/target/linux/generic/pending-4.14/490-ubi-auto-attach-mtd-device-named-ubi-or-data-on-boot.patch
+++ b/target/linux/generic/pending-4.14/490-ubi-auto-attach-mtd-device-named-ubi-or-data-on-boot.patch
@@ -8,7 +8,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
--- a/drivers/mtd/ubi/build.c
+++ b/drivers/mtd/ubi/build.c
-@@ -1157,6 +1157,49 @@ static struct mtd_info * __init open_mtd
+@@ -1168,6 +1168,49 @@ static struct mtd_info * __init open_mtd
return mtd;
}
@@ -58,7 +58,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
static int __init ubi_init(void)
{
int err, i, k;
-@@ -1240,6 +1283,12 @@ static int __init ubi_init(void)
+@@ -1251,6 +1294,12 @@ static int __init ubi_init(void)
}
}
diff --git a/target/linux/ipq40xx/patches-4.14/400-mtd-ubi-add-quirk-to-autoload-ubi-on-rt-ac58u.patch b/target/linux/ipq40xx/patches-4.14/400-mtd-ubi-add-quirk-to-autoload-ubi-on-rt-ac58u.patch
index 86cb454619..8a9da2c088 100644
--- a/target/linux/ipq40xx/patches-4.14/400-mtd-ubi-add-quirk-to-autoload-ubi-on-rt-ac58u.patch
+++ b/target/linux/ipq40xx/patches-4.14/400-mtd-ubi-add-quirk-to-autoload-ubi-on-rt-ac58u.patch
@@ -17,7 +17,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
--- a/drivers/mtd/ubi/build.c
+++ b/drivers/mtd/ubi/build.c
-@@ -1170,6 +1170,9 @@ static void __init ubi_auto_attach(void)
+@@ -1181,6 +1181,9 @@ static void __init ubi_auto_attach(void)
mtd = open_mtd_device("ubi");
if (IS_ERR(mtd))
mtd = open_mtd_device("data");
diff --git a/target/linux/mediatek/patches-4.14/0006-reset-mediatek-mt2701-reset-driver.patch b/target/linux/mediatek/patches-4.14/0006-reset-mediatek-mt2701-reset-driver.patch
index a0fdc14f78..a443adfe64 100644
--- a/target/linux/mediatek/patches-4.14/0006-reset-mediatek-mt2701-reset-driver.patch
+++ b/target/linux/mediatek/patches-4.14/0006-reset-mediatek-mt2701-reset-driver.patch
@@ -16,7 +16,7 @@ Acked-by: Philipp Zabel <p.zabel@pengutronix.de>
--- a/drivers/clk/mediatek/clk-mt2701.c
+++ b/drivers/clk/mediatek/clk-mt2701.c
-@@ -771,6 +771,8 @@ static void mtk_infrasys_init_early(stru
+@@ -772,6 +772,8 @@ static void mtk_infrasys_init_early(stru
if (r)
pr_err("%s(): could not register clock provider: %d\n",
__func__, r);
diff --git a/target/linux/mediatek/patches-4.14/0064-dts.patch b/target/linux/mediatek/patches-4.14/0064-dts.patch
index 47fc2b1b23..cfae4fee64 100644
--- a/target/linux/mediatek/patches-4.14/0064-dts.patch
+++ b/target/linux/mediatek/patches-4.14/0064-dts.patch
@@ -11,7 +11,7 @@
cpus {
cpu@0 {
proc-supply = <&mt6323_vproc_reg>;
-@@ -84,6 +88,10 @@
+@@ -102,6 +106,10 @@
memory@80000000 {
reg = <0 0x80000000 0 0x40000000>;
};
@@ -22,7 +22,7 @@
};
&cir {
-@@ -111,11 +119,24 @@
+@@ -129,11 +137,24 @@
};
};
@@ -49,7 +49,7 @@
compatible = "mediatek,mt7530";
#address-cells = <1>;
#size-cells = <0>;
-@@ -125,6 +146,8 @@
+@@ -143,6 +164,8 @@
core-supply = <&mt6323_vpa_reg>;
io-supply = <&mt6323_vemc3v3_reg>;
@@ -58,7 +58,7 @@
ports {
#address-cells = <1>;
#size-cells = <0>;
-@@ -133,29 +156,46 @@
+@@ -151,29 +174,46 @@
port@0 {
reg = <0>;
label = "wan";
@@ -106,7 +106,7 @@
reg = <6>;
label = "cpu";
ethernet = <&gmac0>;
-@@ -168,8 +208,6 @@
+@@ -186,8 +226,6 @@
};
};
};