aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/01_leds4
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/config-4.41
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt10
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-ap121f.c103
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
-rw-r--r--target/linux/ar71xx/image/generic.mk13
-rw-r--r--target/linux/ar71xx/mikrotik/config-default1
-rw-r--r--target/linux/ar71xx/nand/config-default1
13 files changed, 143 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/01_leds b/target/linux/ar71xx/base-files/etc/board.d/01_leds
index 8eaa892b4a..84b1a7dfd9 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/01_leds
+++ b/target/linux/ar71xx/base-files/etc/board.d/01_leds
@@ -48,6 +48,10 @@ antrouter-r1)
ucidef_set_led_wlan "wlan" "WLAN" "$board:green:wlan" "phy0tpt"
ucidef_set_led_default "btc" "BTC" "$board:green:btc" "0"
;;
+ap121f)
+ ucidef_set_led_netdev "lan" "LAN" "$board:green:lan" "eth0"
+ ucidef_set_led_wlan "wlan" "WLAN" "$board:green:wlan" "phy0tpt"
+ ;;
ap531b0|\
sc1750|\
sc450)
diff --git a/target/linux/ar71xx/base-files/etc/board.d/02_network b/target/linux/ar71xx/base-files/etc/board.d/02_network
index b2126c0c94..5889b2bf80 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/02_network
+++ b/target/linux/ar71xx/base-files/etc/board.d/02_network
@@ -63,6 +63,7 @@ ar71xx_setup_interfaces()
antminer-s1|\
antminer-s3|\
antrouter-r1|\
+ ap121f|\
aw-nr580|\
bullet-m|\
c-55|\
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index 75f0826859..7753a7156d 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -30,6 +30,9 @@ get_status_led() {
xd3200)
status_led="$board:green:system"
;;
+ ap121f)
+ status_led="$board:green:vpn"
+ ;;
ap132|\
ap531b0|\
cpe505n|\
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 5c29a3f0d0..7fd5fb4522 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -416,6 +416,9 @@ ar71xx_board_detect() {
*"AP121-MINI")
name="ap121-mini"
;;
+ *"AP121F")
+ name="ap121f"
+ ;;
*"AP132 reference board")
name="ap132"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 949cb6aed5..05b5634aa5 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -203,6 +203,7 @@ platform_check_image() {
airgatewaypro|\
airgateway|\
airrouter|\
+ ap121f|\
ap132|\
ap531b0|\
ap90q|\
diff --git a/target/linux/ar71xx/config-4.4 b/target/linux/ar71xx/config-4.4
index e8d907fcd3..70793af3a3 100644
--- a/target/linux/ar71xx/config-4.4
+++ b/target/linux/ar71xx/config-4.4
@@ -42,6 +42,7 @@ CONFIG_ATH79_MACH_ANTMINER_S1=y
CONFIG_ATH79_MACH_ANTMINER_S3=y
CONFIG_ATH79_MACH_ANTROUTER_R1=y
CONFIG_ATH79_MACH_AP121=y
+CONFIG_ATH79_MACH_AP121F=y
CONFIG_ATH79_MACH_AP132=y
CONFIG_ATH79_MACH_AP136=y
CONFIG_ATH79_MACH_AP143=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 055dddf33d..ff9c3037a1 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -16,6 +16,16 @@ config ATH79_MACH_ALFA_AP120C
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
+config ATH79_MACH_AP121F
+ bool "ALFA Network AP121F support"
+ select SOC_AR933X
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_ALFA_AP96
bool "ALFA Network AP96 board support"
select SOC_AR71XX
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 3f589f7e2e..469b6a794c 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -48,6 +48,7 @@ obj-$(CONFIG_ATH79_MACH_ANTMINER_S1) += mach-antminer-s1.o
obj-$(CONFIG_ATH79_MACH_ANTMINER_S3) += mach-antminer-s3.o
obj-$(CONFIG_ATH79_MACH_ANTROUTER_R1) += mach-antrouter-r1.o
obj-$(CONFIG_ATH79_MACH_AP121) += mach-ap121.o
+obj-$(CONFIG_ATH79_MACH_AP121F) += mach-ap121f.o
obj-$(CONFIG_ATH79_MACH_AP132) += mach-ap132.o
obj-$(CONFIG_ATH79_MACH_AP136) += mach-ap136.o
obj-$(CONFIG_ATH79_MACH_AP143) += mach-ap143.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-ap121f.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-ap121f.c
new file mode 100644
index 0000000000..955b7faf63
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-ap121f.c
@@ -0,0 +1,103 @@
+/*
+ * ALFA Network AP121F board support
+ *
+ * Copyright (C) 2017 Piotr Dymacz <pepe2k@gmail.com>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define AP121F_GPIO_LED_LAN 17
+#define AP121F_GPIO_LED_VPN 27
+#define AP121F_GPIO_LED_WLAN 0
+
+#define AP121F_GPIO_MICROSD_EN 26
+
+#define AP121F_GPIO_BTN_RESET 12
+#define AP121F_GPIO_BTN_SWITCH 21
+
+#define AP121F_KEYS_POLL_INTERVAL 20
+#define AP121F_KEYS_DEBOUNCE_INTERVAL (3 * AP121F_KEYS_POLL_INTERVAL)
+
+#define AP121F_WMAC_CALDATA_OFFSET 0x1000
+
+static struct gpio_led ap121f_leds_gpio[] __initdata = {
+ {
+ .name = "ap121f:green:lan",
+ .gpio = AP121F_GPIO_LED_LAN,
+ .active_low = 1,
+ }, {
+ .name = "ap121f:green:vpn",
+ .gpio = AP121F_GPIO_LED_VPN,
+ .active_low = 1,
+ }, {
+ .name = "ap121f:green:wlan",
+ .gpio = AP121F_GPIO_LED_WLAN,
+ .active_low = 0,
+ },
+};
+
+static struct gpio_keys_button ap121f_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = AP121F_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = AP121F_GPIO_BTN_RESET,
+ .active_low = 1,
+ }, {
+ .desc = "switch",
+ .type = EV_KEY,
+ .code = BTN_0,
+ .debounce_interval = AP121F_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = AP121F_GPIO_BTN_SWITCH,
+ .active_low = 0,
+ },
+};
+
+static void __init ap121f_setup(void)
+{
+ u8 *art = (u8 *) KSEG1ADDR(0x1f040000);
+
+ ath79_register_m25p80(NULL);
+
+ ath79_setup_ar933x_phy4_switch(false, false);
+
+ /* LAN */
+ ath79_register_mdio(0, 0x0);
+ ath79_init_mac(ath79_eth0_data.mac_addr, art, 0);
+ ath79_register_eth(0);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(ap121f_leds_gpio),
+ ap121f_leds_gpio);
+
+ ath79_register_gpio_keys_polled(-1, AP121F_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(ap121f_gpio_keys),
+ ap121f_gpio_keys);
+
+ gpio_request_one(AP121F_GPIO_MICROSD_EN,
+ GPIOF_OUT_INIT_HIGH | GPIOF_EXPORT_DIR_FIXED,
+ "microSD enable");
+
+ ath79_register_wmac(art + AP121F_WMAC_CALDATA_OFFSET, NULL);
+
+ ath79_register_usb();
+}
+
+MIPS_MACHINE(ATH79_MACH_AP121F, "AP121F", "ALFA Network AP121F", ap121f_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index 0b70256338..5bc50a42ff 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -30,6 +30,7 @@ enum ath79_mach_type {
ATH79_MACH_ANTROUTER_R1, /* Antrouter R1 */
ATH79_MACH_AP121, /* Atheros AP121 reference board */
ATH79_MACH_AP121_MINI, /* Atheros AP121-MINI reference board */
+ ATH79_MACH_AP121F, /* ALFA Network AP121F */
ATH79_MACH_AP132, /* Atheros AP132 reference board */
ATH79_MACH_AP135_020, /* Atheros AP135-020 reference board */
ATH79_MACH_AP136_010, /* Atheros AP136-010 reference board */
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 3f1486ed63..01c5bdc677 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -75,6 +75,19 @@ define Build/wrgg-pad-rootfs
endef
+define Device/ap121f
+ DEVICE_TITLE := ALFA Network AP121F
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage -swconfig
+ BOARDNAME := AP121F
+ IMAGE_SIZE := 16064k
+ CONSOLE := ttyATH0,115200
+ MTDPARTS := spi0.0:192k(u-boot)ro,64k(u-boot-env),64k(art)ro,-(firmware)
+ SUPPORTED_DEVICES := ap121f
+ IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += ap121f
+
define Device/ap531b0
DEVICE_TITLE := Rockeetech AP531B0
DEVICE_PACKAGES := kmod-usb-core kmod-usb2
diff --git a/target/linux/ar71xx/mikrotik/config-default b/target/linux/ar71xx/mikrotik/config-default
index 6c81bc2de5..34c2fc1f0f 100644
--- a/target/linux/ar71xx/mikrotik/config-default
+++ b/target/linux/ar71xx/mikrotik/config-default
@@ -9,6 +9,7 @@
# CONFIG_ATH79_MACH_ANTMINER_S3 is not set
# CONFIG_ATH79_MACH_ANTROUTER_R1 is not set
# CONFIG_ATH79_MACH_AP121 is not set
+# CONFIG_ATH79_MACH_AP121F is not set
# CONFIG_ATH79_MACH_AP132 is not set
# CONFIG_ATH79_MACH_AP136 is not set
# CONFIG_ATH79_MACH_AP143 is not set
diff --git a/target/linux/ar71xx/nand/config-default b/target/linux/ar71xx/nand/config-default
index 6eff5d0b28..57318b38e8 100644
--- a/target/linux/ar71xx/nand/config-default
+++ b/target/linux/ar71xx/nand/config-default
@@ -8,6 +8,7 @@
# CONFIG_ATH79_MACH_ANTMINER_S3 is not set
# CONFIG_ATH79_MACH_ANTROUTER_R1 is not set
# CONFIG_ATH79_MACH_AP121 is not set
+# CONFIG_ATH79_MACH_AP121F is not set
# CONFIG_ATH79_MACH_AP132 is not set
# CONFIG_ATH79_MACH_AP136 is not set
# CONFIG_ATH79_MACH_AP143 is not set