aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/brcm2708/patches-4.14/950-0024-kbuild-Ignore-dtco-targets-when-filtering-symbols.patch2
-rw-r--r--target/linux/brcm2708/patches-4.14/950-0037-Add-dwc_otg-driver.patch4
-rw-r--r--target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch2
4 files changed, 6 insertions, 6 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 32d71c2fe4..3a38c4ffb6 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -3,11 +3,11 @@
LINUX_RELEASE?=1
LINUX_VERSION-4.9 = .172
-LINUX_VERSION-4.14 = .114
+LINUX_VERSION-4.14 = .115
LINUX_VERSION-4.19 = .37
LINUX_KERNEL_HASH-4.9.172 = 49428e30989cc0b069a6f4b7bc08988deb02d10f910ca0c4d1e44b22155eb40e
-LINUX_KERNEL_HASH-4.14.114 = b75e1dcfabc8d18051a07cbf9b60eaee8ac470a2311fed20447fd0d022c19e15
+LINUX_KERNEL_HASH-4.14.115 = b7ae61711a1323053d68fd47911b92977afd526d302755518e42744251516186
LINUX_KERNEL_HASH-4.19.37 = ecb0b30ec32c0c7d614c394158c7d37099a815507ed62235cca32052d7ff9c65
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
diff --git a/target/linux/brcm2708/patches-4.14/950-0024-kbuild-Ignore-dtco-targets-when-filtering-symbols.patch b/target/linux/brcm2708/patches-4.14/950-0024-kbuild-Ignore-dtco-targets-when-filtering-symbols.patch
index c1c555b940..7bfecf6674 100644
--- a/target/linux/brcm2708/patches-4.14/950-0024-kbuild-Ignore-dtco-targets-when-filtering-symbols.patch
+++ b/target/linux/brcm2708/patches-4.14/950-0024-kbuild-Ignore-dtco-targets-when-filtering-symbols.patch
@@ -9,7 +9,7 @@ Subject: [PATCH 024/454] kbuild: Ignore dtco targets when filtering symbols
--- a/scripts/Kbuild.include
+++ b/scripts/Kbuild.include
-@@ -294,7 +294,7 @@ ksym_dep_filter =
+@@ -292,7 +292,7 @@ ksym_dep_filter =
$(CPP) $(call flags_nodeps,c_flags) -D__KSYM_DEPS__ $< ;; \
as_*_S|cpp_s_S) \
$(CPP) $(call flags_nodeps,a_flags) -D__KSYM_DEPS__ $< ;; \
diff --git a/target/linux/brcm2708/patches-4.14/950-0037-Add-dwc_otg-driver.patch b/target/linux/brcm2708/patches-4.14/950-0037-Add-dwc_otg-driver.patch
index f11406ed57..b80a38d6a8 100644
--- a/target/linux/brcm2708/patches-4.14/950-0037-Add-dwc_otg-driver.patch
+++ b/target/linux/brcm2708/patches-4.14/950-0037-Add-dwc_otg-driver.patch
@@ -841,7 +841,7 @@ Signed-off-by: Malik Olivier Boussejra <malik@boussejra.com>
}
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
-@@ -5094,7 +5094,7 @@ static void port_event(struct usb_hub *h
+@@ -5091,7 +5091,7 @@ static void port_event(struct usb_hub *h
if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
u16 status = 0, unused;
@@ -852,7 +852,7 @@ Signed-off-by: Malik Olivier Boussejra <malik@boussejra.com>
msleep(100); /* Cool down */
--- a/drivers/usb/core/message.c
+++ b/drivers/usb/core/message.c
-@@ -1924,6 +1924,85 @@ free_interfaces:
+@@ -1923,6 +1923,85 @@ free_interfaces:
if (cp->string == NULL &&
!(dev->quirks & USB_QUIRK_CONFIG_INTF_STRINGS))
cp->string = usb_cache_string(dev, cp->desc.iConfiguration);
diff --git a/target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch b/target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch
index fc1de9cbc3..b60b20049a 100644
--- a/target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch
+++ b/target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch
@@ -106,7 +106,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
case '-':
--- a/drivers/net/team/team.c
+++ b/drivers/net/team/team.c
-@@ -1947,7 +1947,8 @@ static int team_netpoll_setup(struct net
+@@ -1953,7 +1953,8 @@ static int team_netpoll_setup(struct net
}
#endif