aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/uboot-sunxi/Makefile7
-rw-r--r--target/linux/sunxi/image/cortex-a7.mk10
2 files changed, 17 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 1d920507c7..1e3883dfb4 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -156,6 +156,12 @@ define U-Boot/orangepi_zero
BUILD_DEVICES:=sun8i-h2-plus-orangepi-zero
endef
+define U-Boot/orangepi_one
+ BUILD_SUBTARGET:=cortexa7
+ NAME:=Orange Pi One (H3)
+ BUILD_DEVICES:=sun8i-h3-orangepi-one
+endef
+
define U-Boot/orangepi_pc
BUILD_SUBTARGET:=cortexa7
NAME:=Orange Pi PC (H3)
@@ -260,6 +266,7 @@ UBOOT_TARGETS := \
nanopi_neo2 \
orangepi_zero \
orangepi_r1 \
+ orangepi_one \
orangepi_pc \
orangepi_plus \
orangepi_2 \
diff --git a/target/linux/sunxi/image/cortex-a7.mk b/target/linux/sunxi/image/cortex-a7.mk
index 58c3b6fc40..a9045c7d5a 100644
--- a/target/linux/sunxi/image/cortex-a7.mk
+++ b/target/linux/sunxi/image/cortex-a7.mk
@@ -159,6 +159,16 @@ endef
TARGET_DEVICES += sun8i-h3-nanopi-neo
+define Device/sun8i-h3-orangepi-one
+ DEVICE_TITLE:=Xunlong Orange Pi One
+ DEVICE_PACKAGES:=kmod-rtc-sunxi
+ SUPPORTED_DEVICES:=xunlong,orangepi-one
+ SUNXI_DTS:=sun8i-h3-orangepi-one
+endef
+
+TARGET_DEVICES += sun8i-h3-orangepi-one
+
+
define Device/sun8i-h3-orangepi-pc
DEVICE_TITLE:=Xunlong Orange Pi PC
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug