aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/bcm53xx/patches-4.9/033-0018-ARM-dts-BCM5301X-Specify-serial-console-params-in-dt.patch2
-rw-r--r--target/linux/brcm2708/patches-4.9/950-0084-Support-for-Blokas-Labs-pisound-board.patch4
-rw-r--r--target/linux/generic/hack-4.9/721-phy_packets.patch2
-rw-r--r--target/linux/generic/pending-4.9/680-NET-skip-GRO-for-foreign-MAC-addresses.patch8
-rw-r--r--target/linux/layerscape/patches-4.9/601-net-support-layerscape.patch2
-rw-r--r--target/linux/mediatek/patches-4.9/0048-net-core-add-RPS-balancer.patch6
-rw-r--r--target/linux/ramips/patches-4.9/0067-enable-mt7621-xhci.patch14
-rw-r--r--target/linux/ramips/patches-4.9/0085-pinmux-util.patch77
-rw-r--r--target/linux/ramips/patches-4.9/301-fix-rt3883.patch9
10 files changed, 14 insertions, 114 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index ab2eaeb6ec..eb41da3d2f 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -4,11 +4,11 @@ LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .71
LINUX_VERSION-4.4 = .91
-LINUX_VERSION-4.9 = .53
+LINUX_VERSION-4.9 = .54
LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
LINUX_KERNEL_HASH-4.4.91 = cb9d2b8c1afe58414de5bc7d65429cc9f5f37c80fc229d0e83c55c5c3c254ffb
-LINUX_KERNEL_HASH-4.9.53 = 32915a33bb0b993b779257748f89f31418992edba53acbe1160cb0f8ef3cb324
+LINUX_KERNEL_HASH-4.9.54 = 651005db6efbce4fcd607415ebd697dd8d2f5a2abc2c632b11ece03a1a210fc5
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
diff --git a/target/linux/bcm53xx/patches-4.9/033-0018-ARM-dts-BCM5301X-Specify-serial-console-params-in-dt.patch b/target/linux/bcm53xx/patches-4.9/033-0018-ARM-dts-BCM5301X-Specify-serial-console-params-in-dt.patch
index d174adc0b8..94498e892f 100644
--- a/target/linux/bcm53xx/patches-4.9/033-0018-ARM-dts-BCM5301X-Specify-serial-console-params-in-dt.patch
+++ b/target/linux/bcm53xx/patches-4.9/033-0018-ARM-dts-BCM5301X-Specify-serial-console-params-in-dt.patch
@@ -157,5 +157,5 @@ Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
- };
-
memory {
- reg = <0x00000000 0x10000000>;
+ reg = <0x80000000 0x10000000>;
};
diff --git a/target/linux/brcm2708/patches-4.9/950-0084-Support-for-Blokas-Labs-pisound-board.patch b/target/linux/brcm2708/patches-4.9/950-0084-Support-for-Blokas-Labs-pisound-board.patch
index 21f43347b3..1033326614 100644
--- a/target/linux/brcm2708/patches-4.9/950-0084-Support-for-Blokas-Labs-pisound-board.patch
+++ b/target/linux/brcm2708/patches-4.9/950-0084-Support-for-Blokas-Labs-pisound-board.patch
@@ -19,8 +19,8 @@ Print a logline when the kernel module is removed.
--- a/Documentation/devicetree/bindings/vendor-prefixes.txt
+++ b/Documentation/devicetree/bindings/vendor-prefixes.txt
-@@ -40,6 +40,7 @@ auvidea Auvidea GmbH
- avago Avago Technologies
+@@ -41,6 +41,7 @@ avago Avago Technologies
+ avia avia semiconductor
avic Shanghai AVIC Optoelectronics Co., Ltd.
axis Axis Communications AB
+blokaslabs Vilniaus Blokas UAB
diff --git a/target/linux/generic/hack-4.9/721-phy_packets.patch b/target/linux/generic/hack-4.9/721-phy_packets.patch
index 8b607ac89b..0d47c7621b 100644
--- a/target/linux/generic/hack-4.9/721-phy_packets.patch
+++ b/target/linux/generic/hack-4.9/721-phy_packets.patch
@@ -101,7 +101,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
help
--- a/net/core/dev.c
+++ b/net/core/dev.c
-@@ -2939,10 +2939,20 @@ static int xmit_one(struct sk_buff *skb,
+@@ -2942,10 +2942,20 @@ static int xmit_one(struct sk_buff *skb,
if (!list_empty(&ptype_all) || !list_empty(&dev->ptype_all))
dev_queue_xmit_nit(skb, dev);
diff --git a/target/linux/generic/pending-4.9/680-NET-skip-GRO-for-foreign-MAC-addresses.patch b/target/linux/generic/pending-4.9/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
index cfa0a69fb3..ad0fb5bdc5 100644
--- a/target/linux/generic/pending-4.9/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
+++ b/target/linux/generic/pending-4.9/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
@@ -34,7 +34,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
__u16 tc_index; /* traffic control index */
--- a/net/core/dev.c
+++ b/net/core/dev.c
-@@ -4520,6 +4520,9 @@ static enum gro_result dev_gro_receive(s
+@@ -4523,6 +4523,9 @@ static enum gro_result dev_gro_receive(s
enum gro_result ret;
int grow;
@@ -44,7 +44,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
if (!(skb->dev->features & NETIF_F_GRO))
goto normal;
-@@ -5808,6 +5811,48 @@ static void __netdev_adjacent_dev_unlink
+@@ -5811,6 +5814,48 @@ static void __netdev_adjacent_dev_unlink
&upper_dev->adj_list.lower);
}
@@ -93,7 +93,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
static int __netdev_upper_dev_link(struct net_device *dev,
struct net_device *upper_dev, bool master,
void *upper_priv, void *upper_info)
-@@ -6006,6 +6051,8 @@ void netdev_upper_dev_unlink(struct net_
+@@ -6009,6 +6054,8 @@ void netdev_upper_dev_unlink(struct net_
list_for_each_entry(i, &upper_dev->all_adj_list.upper, list)
__netdev_adjacent_dev_unlink(dev, i->dev, i->ref_nr);
@@ -102,7 +102,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
call_netdevice_notifiers_info(NETDEV_CHANGEUPPER, dev,
&changeupper_info.info);
}
-@@ -6606,6 +6653,7 @@ int dev_set_mac_address(struct net_devic
+@@ -6609,6 +6656,7 @@ int dev_set_mac_address(struct net_devic
if (err)
return err;
dev->addr_assign_type = NET_ADDR_SET;
diff --git a/target/linux/layerscape/patches-4.9/601-net-support-layerscape.patch b/target/linux/layerscape/patches-4.9/601-net-support-layerscape.patch
index 1c80ae5adc..d114b49b39 100644
--- a/target/linux/layerscape/patches-4.9/601-net-support-layerscape.patch
+++ b/target/linux/layerscape/patches-4.9/601-net-support-layerscape.patch
@@ -2167,7 +2167,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
static int br_change_mtu(struct net_device *dev, int new_mtu)
--- a/net/core/dev.c
+++ b/net/core/dev.c
-@@ -6600,9 +6600,18 @@ int dev_set_mtu(struct net_device *dev,
+@@ -6603,9 +6603,18 @@ int dev_set_mtu(struct net_device *dev,
if (new_mtu == dev->mtu)
return 0;
diff --git a/target/linux/mediatek/patches-4.9/0048-net-core-add-RPS-balancer.patch b/target/linux/mediatek/patches-4.9/0048-net-core-add-RPS-balancer.patch
index 6a34cf2f26..fca43cbdf3 100644
--- a/target/linux/mediatek/patches-4.9/0048-net-core-add-RPS-balancer.patch
+++ b/target/linux/mediatek/patches-4.9/0048-net-core-add-RPS-balancer.patch
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
--- a/net/core/dev.c
+++ b/net/core/dev.c
-@@ -3547,6 +3547,58 @@ set_rps_cpu(struct net_device *dev, stru
+@@ -3550,6 +3550,58 @@ set_rps_cpu(struct net_device *dev, stru
return rflow;
}
@@ -69,7 +69,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
/*
* get_rps_cpu is called from netif_receive_skb and returns the target
* CPU from the RPS map of the receiving queue for a given skb.
-@@ -3636,7 +3688,7 @@ static int get_rps_cpu(struct net_device
+@@ -3639,7 +3691,7 @@ static int get_rps_cpu(struct net_device
try_rps:
if (map) {
@@ -78,7 +78,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
if (cpu_online(tcpu)) {
cpu = tcpu;
goto done;
-@@ -8427,6 +8479,9 @@ static int __init net_dev_init(void)
+@@ -8430,6 +8482,9 @@ static int __init net_dev_init(void)
sd->backlog.weight = weight_p;
}
diff --git a/target/linux/ramips/patches-4.9/0067-enable-mt7621-xhci.patch b/target/linux/ramips/patches-4.9/0067-enable-mt7621-xhci.patch
deleted file mode 100644
index 6e13e626cd..0000000000
--- a/target/linux/ramips/patches-4.9/0067-enable-mt7621-xhci.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/drivers/usb/host/Kconfig
-+++ b/drivers/usb/host/Kconfig
-@@ -45,9 +45,9 @@ config USB_XHCI_PLATFORM
- If unsure, say N.
-
- config USB_XHCI_MTK
-- tristate "xHCI support for Mediatek MT65xx"
-+ tristate "xHCI support for Mediatek MT65xx/MT7621"
- select MFD_SYSCON
-- depends on ARCH_MEDIATEK || COMPILE_TEST
-+ depends on SOC_MT7621 || ARCH_MEDIATEK || COMPILE_TEST
- ---help---
- Say 'Y' to enable the support for the xHCI host controller
- found in Mediatek MT65xx SoCs.
diff --git a/target/linux/ramips/patches-4.9/0085-pinmux-util.patch b/target/linux/ramips/patches-4.9/0085-pinmux-util.patch
deleted file mode 100644
index e891bc166b..0000000000
--- a/target/linux/ramips/patches-4.9/0085-pinmux-util.patch
+++ /dev/null
@@ -1,77 +0,0 @@
---- a/arch/mips/ralink/mt7620.c
-+++ b/arch/mips/ralink/mt7620.c
-@@ -176,7 +176,7 @@ static struct rt2880_pmx_func spi_cs1_gr
-
- static struct rt2880_pmx_func spis_grp_mt7628[] = {
- FUNC("pwm_uart2", 3, 14, 4),
-- FUNC("util", 2, 14, 4),
-+ FUNC("utif", 2, 14, 4),
- FUNC("gpio", 1, 14, 4),
- FUNC("spis", 0, 14, 4),
- };
-@@ -190,28 +190,28 @@ static struct rt2880_pmx_func gpio_grp_m
-
- static struct rt2880_pmx_func p4led_kn_grp_mt7628[] = {
- FUNC("jtag", 3, 30, 1),
-- FUNC("util", 2, 30, 1),
-+ FUNC("utif", 2, 30, 1),
- FUNC("gpio", 1, 30, 1),
- FUNC("p4led_kn", 0, 30, 1),
- };
-
- static struct rt2880_pmx_func p3led_kn_grp_mt7628[] = {
- FUNC("jtag", 3, 31, 1),
-- FUNC("util", 2, 31, 1),
-+ FUNC("utif", 2, 31, 1),
- FUNC("gpio", 1, 31, 1),
- FUNC("p3led_kn", 0, 31, 1),
- };
-
- static struct rt2880_pmx_func p2led_kn_grp_mt7628[] = {
- FUNC("jtag", 3, 32, 1),
-- FUNC("util", 2, 32, 1),
-+ FUNC("utif", 2, 32, 1),
- FUNC("gpio", 1, 32, 1),
- FUNC("p2led_kn", 0, 32, 1),
- };
-
- static struct rt2880_pmx_func p1led_kn_grp_mt7628[] = {
- FUNC("jtag", 3, 33, 1),
-- FUNC("util", 2, 33, 1),
-+ FUNC("utif", 2, 33, 1),
- FUNC("gpio", 1, 33, 1),
- FUNC("p1led_kn", 0, 33, 1),
- };
-@@ -232,28 +232,28 @@ static struct rt2880_pmx_func wled_kn_gr
-
- static struct rt2880_pmx_func p4led_an_grp_mt7628[] = {
- FUNC("jtag", 3, 39, 1),
-- FUNC("util", 2, 39, 1),
-+ FUNC("utif", 2, 39, 1),
- FUNC("gpio", 1, 39, 1),
- FUNC("p4led_an", 0, 39, 1),
- };
-
- static struct rt2880_pmx_func p3led_an_grp_mt7628[] = {
- FUNC("jtag", 3, 40, 1),
-- FUNC("util", 2, 40, 1),
-+ FUNC("utif", 2, 40, 1),
- FUNC("gpio", 1, 40, 1),
- FUNC("p3led_an", 0, 40, 1),
- };
-
- static struct rt2880_pmx_func p2led_an_grp_mt7628[] = {
- FUNC("jtag", 3, 41, 1),
-- FUNC("util", 2, 41, 1),
-+ FUNC("utif", 2, 41, 1),
- FUNC("gpio", 1, 41, 1),
- FUNC("p2led_an", 0, 41, 1),
- };
-
- static struct rt2880_pmx_func p1led_an_grp_mt7628[] = {
- FUNC("jtag", 3, 42, 1),
-- FUNC("util", 2, 42, 1),
-+ FUNC("utif", 2, 42, 1),
- FUNC("gpio", 1, 42, 1),
- FUNC("p1led_an", 0, 42, 1),
- };
diff --git a/target/linux/ramips/patches-4.9/301-fix-rt3883.patch b/target/linux/ramips/patches-4.9/301-fix-rt3883.patch
deleted file mode 100644
index 5b79526894..0000000000
--- a/target/linux/ramips/patches-4.9/301-fix-rt3883.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- a/arch/mips/ralink/rt3883.c
-+++ b/arch/mips/ralink/rt3883.c
-@@ -147,5 +147,5 @@ void prom_soc_init(struct ralink_soc_inf
-
- rt2880_pinmux_data = rt3883_pinmux_data;
-
-- ralink_soc == RT3883_SOC;
-+ ralink_soc = RT3883_SOC;
- }