aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/generic/config-4.41
-rw-r--r--target/linux/generic/patches-4.4/074-NET-PHY-adds-driver-for-lantiq-PHY11G.patch (renamed from target/linux/lantiq/patches-4.4/0023-NET-PHY-adds-driver-for-lantiq-PHY11G.patch)8
-rw-r--r--target/linux/generic/patches-4.4/720-phy_adm6996.patch6
-rw-r--r--target/linux/generic/patches-4.4/722-phy_mvswitch.patch2
-rw-r--r--target/linux/generic/patches-4.4/723-phy_ip175c.patch2
-rw-r--r--target/linux/generic/patches-4.4/724-phy_ar8216.patch2
-rw-r--r--target/linux/generic/patches-4.4/725-phy_rtl8306.patch2
-rw-r--r--target/linux/generic/patches-4.4/726-phy_rtl8366.patch2
-rw-r--r--target/linux/generic/patches-4.4/727-phy-rtl8367.patch2
-rw-r--r--target/linux/generic/patches-4.4/728-phy-rtl8367b.patch2
-rw-r--r--target/linux/generic/patches-4.4/729-phy-tantos.patch2
-rw-r--r--target/linux/generic/patches-4.4/730-phy_b53.patch2
-rw-r--r--target/linux/generic/patches-4.4/732-phy-ar8216-led-support.patch2
-rw-r--r--target/linux/generic/patches-4.4/733-phy_mvsw61xx.patch2
-rw-r--r--target/linux/lantiq/config-4.41
15 files changed, 19 insertions, 19 deletions
diff --git a/target/linux/generic/config-4.4 b/target/linux/generic/config-4.4
index e3458c1de8..1c0af9597f 100644
--- a/target/linux/generic/config-4.4
+++ b/target/linux/generic/config-4.4
@@ -1883,6 +1883,7 @@ CONFIG_KUSER_HELPERS=y
# CONFIG_L2TP_V3 is not set
# CONFIG_LANMEDIA is not set
# CONFIG_LANTIQ is not set
+# CONFIG_LANTIQ_PHY is not set
# CONFIG_LAPB is not set
# CONFIG_LASAT is not set
# CONFIG_LATENCYTOP is not set
diff --git a/target/linux/lantiq/patches-4.4/0023-NET-PHY-adds-driver-for-lantiq-PHY11G.patch b/target/linux/generic/patches-4.4/074-NET-PHY-adds-driver-for-lantiq-PHY11G.patch
index 3af676297d..e24099ef45 100644
--- a/target/linux/lantiq/patches-4.4/0023-NET-PHY-adds-driver-for-lantiq-PHY11G.patch
+++ b/target/linux/generic/patches-4.4/074-NET-PHY-adds-driver-for-lantiq-PHY11G.patch
@@ -13,9 +13,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -202,6 +202,11 @@ config RTL8306_PHY
- tristate "Driver for Realtek RTL8306S switches"
- select SWCONFIG
+@@ -156,6 +156,11 @@ config MICROCHIP_PHY
+ help
+ Supports the LAN88XX PHYs.
+config LANTIQ_PHY
+ tristate "Driver for Lantiq PHYs"
@@ -27,7 +27,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
depends on PHYLIB
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -46,6 +46,7 @@ obj-$(CONFIG_DP83848_PHY) += dp83848.o
+@@ -30,6 +30,7 @@ obj-$(CONFIG_DP83848_PHY) += dp83848.o
obj-$(CONFIG_DP83867_PHY) += dp83867.o
obj-$(CONFIG_STE10XP) += ste10Xp.o
obj-$(CONFIG_MICREL_PHY) += micrel.o
diff --git a/target/linux/generic/patches-4.4/720-phy_adm6996.patch b/target/linux/generic/patches-4.4/720-phy_adm6996.patch
index 3ee02f1005..bf939e893c 100644
--- a/target/linux/generic/patches-4.4/720-phy_adm6996.patch
+++ b/target/linux/generic/patches-4.4/720-phy_adm6996.patch
@@ -1,8 +1,8 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -170,6 +170,13 @@ config MICROCHIP_PHY
- help
- Supports the LAN88XX PHYs.
+@@ -175,6 +175,13 @@ config LANTIQ_PHY
+ ---help---
+ Supports the 11G and 22F PHYs.
+config ADM6996_PHY
+ tristate "Driver for ADM6996 switches"
diff --git a/target/linux/generic/patches-4.4/722-phy_mvswitch.patch b/target/linux/generic/patches-4.4/722-phy_mvswitch.patch
index 9cfca24b95..37ec7d9e5d 100644
--- a/target/linux/generic/patches-4.4/722-phy_mvswitch.patch
+++ b/target/linux/generic/patches-4.4/722-phy_mvswitch.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -177,6 +177,10 @@ config ADM6996_PHY
+@@ -182,6 +182,10 @@ config ADM6996_PHY
Currently supports the ADM6996FC and ADM6996M switches.
Support for FC is very limited.
diff --git a/target/linux/generic/patches-4.4/723-phy_ip175c.patch b/target/linux/generic/patches-4.4/723-phy_ip175c.patch
index 60b79a2aae..5eb10bb30f 100644
--- a/target/linux/generic/patches-4.4/723-phy_ip175c.patch
+++ b/target/linux/generic/patches-4.4/723-phy_ip175c.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -181,6 +181,10 @@ config MVSWITCH_PHY
+@@ -186,6 +186,10 @@ config MVSWITCH_PHY
tristate "Driver for Marvell 88E6060 switches"
select ETHERNET_PACKET_MANGLE
diff --git a/target/linux/generic/patches-4.4/724-phy_ar8216.patch b/target/linux/generic/patches-4.4/724-phy_ar8216.patch
index 626a2f3cba..8cd0034334 100644
--- a/target/linux/generic/patches-4.4/724-phy_ar8216.patch
+++ b/target/linux/generic/patches-4.4/724-phy_ar8216.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -185,6 +185,11 @@ config IP17XX_PHY
+@@ -190,6 +190,11 @@ config IP17XX_PHY
tristate "Driver for IC+ IP17xx switches"
select SWCONFIG
diff --git a/target/linux/generic/patches-4.4/725-phy_rtl8306.patch b/target/linux/generic/patches-4.4/725-phy_rtl8306.patch
index f38922f6e1..2bf2760764 100644
--- a/target/linux/generic/patches-4.4/725-phy_rtl8306.patch
+++ b/target/linux/generic/patches-4.4/725-phy_rtl8306.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -190,6 +190,10 @@ config AR8216_PHY
+@@ -195,6 +195,10 @@ config AR8216_PHY
select ETHERNET_PACKET_MANGLE
select SWCONFIG
diff --git a/target/linux/generic/patches-4.4/726-phy_rtl8366.patch b/target/linux/generic/patches-4.4/726-phy_rtl8366.patch
index 5f50cf48b0..53e967b82f 100644
--- a/target/linux/generic/patches-4.4/726-phy_rtl8366.patch
+++ b/target/linux/generic/patches-4.4/726-phy_rtl8366.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -294,6 +294,30 @@ config MDIO_BCM_IPROC
+@@ -299,6 +299,30 @@ config MDIO_BCM_IPROC
This module provides a driver for the MDIO busses found in the
Broadcom iProc SoC's.
diff --git a/target/linux/generic/patches-4.4/727-phy-rtl8367.patch b/target/linux/generic/patches-4.4/727-phy-rtl8367.patch
index 887d12dd95..9fa8c8fc2a 100644
--- a/target/linux/generic/patches-4.4/727-phy-rtl8367.patch
+++ b/target/linux/generic/patches-4.4/727-phy-rtl8367.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -316,6 +316,10 @@ config RTL8366RB_PHY
+@@ -321,6 +321,10 @@ config RTL8366RB_PHY
tristate "Driver for the Realtek RTL8366RB switch"
select SWCONFIG
diff --git a/target/linux/generic/patches-4.4/728-phy-rtl8367b.patch b/target/linux/generic/patches-4.4/728-phy-rtl8367b.patch
index d96bead4dc..12d7fcad90 100644
--- a/target/linux/generic/patches-4.4/728-phy-rtl8367b.patch
+++ b/target/linux/generic/patches-4.4/728-phy-rtl8367b.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -320,6 +320,10 @@ config RTL8367_PHY
+@@ -325,6 +325,10 @@ config RTL8367_PHY
tristate "Driver for the Realtek RTL8367R/M switches"
select SWCONFIG
diff --git a/target/linux/generic/patches-4.4/729-phy-tantos.patch b/target/linux/generic/patches-4.4/729-phy-tantos.patch
index a09032b6c8..3f18c83c42 100644
--- a/target/linux/generic/patches-4.4/729-phy-tantos.patch
+++ b/target/linux/generic/patches-4.4/729-phy-tantos.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -331,3 +331,8 @@ endif # PHYLIB
+@@ -336,3 +336,8 @@ endif # PHYLIB
config MICREL_KS8995MA
tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
depends on SPI
diff --git a/target/linux/generic/patches-4.4/730-phy_b53.patch b/target/linux/generic/patches-4.4/730-phy_b53.patch
index 1a6de96726..4d5ea7a754 100644
--- a/target/linux/generic/patches-4.4/730-phy_b53.patch
+++ b/target/linux/generic/patches-4.4/730-phy_b53.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -326,6 +326,8 @@ config RTL8367B_PHY
+@@ -331,6 +331,8 @@ config RTL8367B_PHY
endif # RTL8366_SMI
diff --git a/target/linux/generic/patches-4.4/732-phy-ar8216-led-support.patch b/target/linux/generic/patches-4.4/732-phy-ar8216-led-support.patch
index f4fea5ce50..799ea494a0 100644
--- a/target/linux/generic/patches-4.4/732-phy-ar8216-led-support.patch
+++ b/target/linux/generic/patches-4.4/732-phy-ar8216-led-support.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -190,6 +190,10 @@ config AR8216_PHY
+@@ -195,6 +195,10 @@ config AR8216_PHY
select ETHERNET_PACKET_MANGLE
select SWCONFIG
diff --git a/target/linux/generic/patches-4.4/733-phy_mvsw61xx.patch b/target/linux/generic/patches-4.4/733-phy_mvsw61xx.patch
index 2e131368b9..4daa9e8c87 100644
--- a/target/linux/generic/patches-4.4/733-phy_mvsw61xx.patch
+++ b/target/linux/generic/patches-4.4/733-phy_mvsw61xx.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -181,6 +181,10 @@ config MVSWITCH_PHY
+@@ -186,6 +186,10 @@ config MVSWITCH_PHY
tristate "Driver for Marvell 88E6060 switches"
select ETHERNET_PACKET_MANGLE
diff --git a/target/linux/lantiq/config-4.4 b/target/linux/lantiq/config-4.4
index 073b7c7cf7..f14fd57ea1 100644
--- a/target/linux/lantiq/config-4.4
+++ b/target/linux/lantiq/config-4.4
@@ -110,7 +110,6 @@ CONFIG_IRQ_WORK=y
CONFIG_LANTIQ=y
CONFIG_LANTIQ_DT_NONE=y
CONFIG_LANTIQ_ETOP=y
-# CONFIG_LANTIQ_PHY is not set
CONFIG_LANTIQ_WDT=y
# CONFIG_LANTIQ_XRX200 is not set
CONFIG_LEDS_GPIO=y