aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/uboot-envtools/files/pistachio2
-rwxr-xr-xtarget/linux/pistachio/base-files/lib/pistachio.sh34
-rwxr-xr-xtarget/linux/pistachio/base-files/lib/preinit/03_preinit_pistachio.sh15
-rwxr-xr-xtarget/linux/pistachio/base-files/lib/upgrade/platform.sh2
-rw-r--r--target/linux/pistachio/image/Makefile1
5 files changed, 3 insertions, 51 deletions
diff --git a/package/boot/uboot-envtools/files/pistachio b/package/boot/uboot-envtools/files/pistachio
index ac82d9da8b..e4aa7b0cd9 100644
--- a/package/boot/uboot-envtools/files/pistachio
+++ b/package/boot/uboot-envtools/files/pistachio
@@ -16,7 +16,7 @@ touch /etc/config/ubootenv
board=$(board_name)
case "$board" in
-marduk)
+img,pistachio-marduk)
ubootenv_add_uci_config "/dev/mtd2" "0x0" "0x2000" "0x1000"
;;
esac
diff --git a/target/linux/pistachio/base-files/lib/pistachio.sh b/target/linux/pistachio/base-files/lib/pistachio.sh
deleted file mode 100755
index 9390a4c0ff..0000000000
--- a/target/linux/pistachio/base-files/lib/pistachio.sh
+++ /dev/null
@@ -1,34 +0,0 @@
-#!/bin/sh
-#
-# Copyright (C) 2017 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-PISTACHIO_BOARD_NAME=
-PISTACHIO_MODEL=
-
-pistachio_board_detect() {
- local machine
- local name
-
- machine=$(cat /proc/device-tree/model)
-
- case "$machine" in
- "IMG Marduk (Creator Ci40)")
- name="marduk"
- ;;
- *)
- name="generic"
- ;;
- esac
-
- [ -z "$PISTACHIO_BOARD_NAME" ] && PISTACHIO_BOARD_NAME="$name"
- [ -z "$PISTACHIO_MODEL" ] && PISTACHIO_MODEL="$machine"
-
- [ -e "/tmp/sysinfo/" ] || mkdir -p "/tmp/sysinfo/"
-
- echo "$PISTACHIO_BOARD_NAME" > /tmp/sysinfo/board_name
- echo "$PISTACHIO_MODEL" > /tmp/sysinfo/model
-}
diff --git a/target/linux/pistachio/base-files/lib/preinit/03_preinit_pistachio.sh b/target/linux/pistachio/base-files/lib/preinit/03_preinit_pistachio.sh
deleted file mode 100755
index fda420e7d7..0000000000
--- a/target/linux/pistachio/base-files/lib/preinit/03_preinit_pistachio.sh
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-#
-# Copyright (C) 2017 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-do_pistachio() {
- . /lib/pistachio.sh
-
- pistachio_board_detect
-}
-
-boot_hook_add preinit_main do_pistachio
diff --git a/target/linux/pistachio/base-files/lib/upgrade/platform.sh b/target/linux/pistachio/base-files/lib/upgrade/platform.sh
index 2ddac783f3..ee5d5066c3 100755
--- a/target/linux/pistachio/base-files/lib/upgrade/platform.sh
+++ b/target/linux/pistachio/base-files/lib/upgrade/platform.sh
@@ -33,7 +33,7 @@ platform_nand_pre_upgrade() {
local board=$(board_name)
case "$board" in
- marduk)
+ img,pistachio-marduk)
local boot_partition=$(dmesg | grep "ubi0: attached.*" | sed "s/^.*\(firmware[0-1]\).*/\1/g")
echo "Current boot partiton $boot_partition (/dev/mtd$(find_mtd_index $boot_partition))"
diff --git a/target/linux/pistachio/image/Makefile b/target/linux/pistachio/image/Makefile
index 88210374de..c1da39e855 100644
--- a/target/linux/pistachio/image/Makefile
+++ b/target/linux/pistachio/image/Makefile
@@ -24,6 +24,7 @@ define Device/Default
endef
define Device/marduk
+ BOARD_NAME := img,pistachio-marduk
DEVICE_DTS := img/pistachio_marduk
BLOCKSIZE := 256KiB
PAGESIZE := 4KiB