aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds4
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network4
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh4
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh8
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh4
-rw-r--r--target/linux/ramips/dts/PSG1218A.dts (renamed from target/linux/ramips/dts/PSG1218K2C.dts)10
-rw-r--r--target/linux/ramips/dts/PSG1218B.dts (renamed from target/linux/ramips/dts/PSG1218.dts)10
-rw-r--r--target/linux/ramips/image/mt7620.mk16
8 files changed, 30 insertions, 30 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 2c44a83f28..3ca390f13f 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -287,8 +287,8 @@ pbr-m1)
psg1208)
set_wifi_led "$board:white:wlan2g"
;;
-psg1218\|
-psg1218k2c)
+psg1218a\|
+psg1218b)
ucidef_set_led_netdev "Network" "Network" "$board:blue:status" "eth0"
ucidef_set_led_default "status" "STATUS" "$board:yellow:status" "0"
;;
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index b2966c26da..a4da5ee60b 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -95,7 +95,7 @@ ramips_setup_interfaces()
oy-0001|\
pbr-m1|\
psg1208|\
- psg1218k2c|\
+ psg1218a|\
r6220|\
sap-g3200u3|\
sk-wb8|\
@@ -115,7 +115,7 @@ ramips_setup_interfaces()
ucidef_add_switch "switch0" \
"0:lan" "1:lan" "2:lan" "3:lan" "4:wan" "6@eth0"
;;
- psg1218)
+ psg1218b)
ucidef_add_switch "switch0" \
"0:lan:3" "1:lan:2" "2:lan:1" "3:wan" "6@eth0"
;;
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index af18264f99..3624efd3b4 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -104,8 +104,8 @@ get_status_led() {
psg1208)
status_led="$board:white:wps"
;;
- psg1218|\
- psg1218k2c)
+ psg1218a|\
+ psg1218b)
status_led="$board:yellow:status"
;;
cy-swr1100|\
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index a75f5208a3..7630166b89 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -397,11 +397,11 @@ ramips_board_detect() {
*"PSG1208")
name="psg1208"
;;
- *"PSG1218")
- name="psg1218"
+ *"PSG1218 rev.A")
+ name="psg1218a"
;;
- *"PSG1218K2C")
- name="psg1218k2c"
+ *"PSG1218 rev.B")
+ name="psg1218b"
;;
*"PSR-680W"*)
name="psr-680w"
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 827109b59e..d0dd28e73f 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -112,8 +112,8 @@ platform_check_image() {
pbr-d1|\
pbr-m1|\
psg1208|\
- psg1218|\
- psg1218k2c|\
+ psg1218a|\
+ psg1218b|\
psr-680w|\
px-4885|\
rb750gr3|\
diff --git a/target/linux/ramips/dts/PSG1218K2C.dts b/target/linux/ramips/dts/PSG1218A.dts
index d8105b9a22..e85ef70cbd 100644
--- a/target/linux/ramips/dts/PSG1218K2C.dts
+++ b/target/linux/ramips/dts/PSG1218A.dts
@@ -3,23 +3,23 @@
#include "PSG1218.dtsi"
/ {
- compatible = "PSG1218K2C", "ralink,mt7620a-soc";
- model = "Phicomm PSG1218K2C";
+ compatible = "PSG1218A", "ralink,mt7620a-soc";
+ model = "Phicomm PSG1218 rev.A";
gpio-leds {
compatible = "gpio-leds";
blue {
- label = "psg1218k2c:blue:status";
+ label = "psg1218a:blue:status";
gpios = <&gpio0 10 1>;
};
yellow {
- label = "psg1218k2c:yellow:status";
+ label = "psg1218a:yellow:status";
gpios = <&gpio0 11 1>;
};
red {
- label = "psg1218k2c:red:status";
+ label = "psg1218a:red:status";
gpios = <&gpio0 8 0>;
};
};
diff --git a/target/linux/ramips/dts/PSG1218.dts b/target/linux/ramips/dts/PSG1218B.dts
index 0492d65502..38ceb95856 100644
--- a/target/linux/ramips/dts/PSG1218.dts
+++ b/target/linux/ramips/dts/PSG1218B.dts
@@ -3,23 +3,23 @@
#include "PSG1218.dtsi"
/ {
- compatible = "PSG1218", "ralink,mt7620a-soc";
- model = "Phicomm PSG1218";
+ compatible = "PSG1218B", "ralink,mt7620a-soc";
+ model = "Phicomm PSG1218 rev.B";
gpio-leds {
compatible = "gpio-leds";
blue {
- label = "psg1218:blue:status";
+ label = "psg1218b:blue:status";
gpios = <&gpio0 10 1>;
};
yellow {
- label = "psg1218:yellow:status";
+ label = "psg1218b:yellow:status";
gpios = <&gpio0 11 1>;
};
red {
- label = "psg1218:red:status";
+ label = "psg1218b:red:status";
gpios = <&gpio0 8 0>;
};
};
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 63d5a7c00a..fcecb7a1c8 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -322,19 +322,19 @@ define Device/psg1208
endef
TARGET_DEVICES += psg1208
-define Device/psg1218
- DTS := PSG1218
- DEVICE_TITLE := Phicomm PSG1218
+define Device/psg1218a
+ DTS := PSG1218A
+ DEVICE_TITLE := Phicomm PSG1218 rev.Ax
DEVICE_PACKAGES := kmod-mt76x2
endef
-TARGET_DEVICES += psg1218
+TARGET_DEVICES += psg1218a
-define Device/psg1218k2c
- DTS := PSG1218K2C
- DEVICE_TITLE := Phicomm PSG1218K2C
+define Device/psg1218b
+ DTS := PSG1218B
+ DEVICE_TITLE := Phicomm PSG1218 rev.Bx
DEVICE_PACKAGES := kmod-mt76x2
endef
-TARGET_DEVICES += psg1218k2c
+TARGET_DEVICES += psg1218b
define Device/rp-n53
DTS := RP-N53