aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/image-commands.mk5
-rw-r--r--target/linux/at91/image/Makefile6
-rw-r--r--target/linux/at91/image/sama5.mk15
3 files changed, 10 insertions, 16 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index adef8f2759..555a9e5906 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -113,11 +113,6 @@ define Build/install-dtb
)
endef
-define Build/install-zImage
- $(CP) $(KDIR)/zImage \
- $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE_SANITIZED)-zImage
-endef
-
define Build/fit
$(TOPDIR)/scripts/mkits.sh \
-D $(DEVICE_NAME) -o $@.its -k $@ \
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 12607073e4..ccaeebe7ca 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -9,6 +9,10 @@ include $(INCLUDE_DIR)/image.mk
KERNEL_LOADADDR := 0x20008000
+define Build/at91-install-zImage
+ $(CP) $(KDIR)/zImage $@
+endef
+
ifeq ($(SUBTARGET),legacy)
include ./legacy.mk
endif
@@ -40,7 +44,7 @@ endef
define Device/evaluation-zImage
IMAGES += zImage
- IMAGE/zImage := install-zImage
+ IMAGE/zImage := at91-install-zImage
endef
define Device/evaluation-dtb
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index b251d714dc..e51a0bce20 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -16,24 +16,19 @@ define Build/at91-sdcard
$(BIN_DIR)/u-boot-$(dts:at91-%=%)_mmc/u-boot.bin \
::u-boot.bin; \
$(CP) $(BIN_DIR)/at91bootstrap-$(dts:at91-%=%)sd_uboot*/*.bin \
- $(BIN_DIR)/BOOT.bin; \
- mcopy -i $@.boot $(BIN_DIR)/BOOT.bin ::BOOT.bin;)
+ $@.BOOT.bin; \
+ mcopy -i $@.boot $@.BOOT.bin ::BOOT.bin;)
./gen_at91_sdcard_img.sh \
- $(dir $@)$(IMG_PREFIX)-$(DEVICE_NAME)-sdcard.img \
+ $@.img \
$@.boot \
$(KDIR)/root.ext4 \
$(AT91_SD_BOOT_PARTSIZE) \
$(CONFIG_TARGET_ROOTFS_PARTSIZE)
- gzip -nc9 $(dir $@)$(IMG_PREFIX)-$(DEVICE_NAME)-sdcard.img \
- > $(dir $@)$(IMG_PREFIX)-$(DEVICE_NAME)-sdcard.img.gz
+ gzip -nc9 $@.img > $@
- $(CP) $(dir $@)$(IMG_PREFIX)-$(DEVICE_NAME)-sdcard.img.gz \
- $(BIN_DIR)/
-
- rm -f $(BIN_DIR)/BOOT.bin
- rm -f $@.boot
+ rm -f $@.img $@.boot $@.BOOT.bin
endef
define Device/evaluation-sdimage