aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/image-commands.mk4
-rw-r--r--target/linux/ipq806x/image/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 04fa853fbb..e0f2918a38 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -110,6 +110,10 @@ define Build/append-rootfs
dd if=$(IMAGE_ROOTFS) >> $@
endef
+define Build/append-file
+ cat "$(1)" >> "$@"
+endef
+
define Build/append-ubi
sh $(TOPDIR)/scripts/ubinize-image.sh \
$(if $(UBOOTENV_IN_UBI),--uboot-env) \
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 3cc48bb905..33dc31d41e 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -31,10 +31,6 @@ define Image/Build
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-root.img bs=2k conv=sync
endef
-define Build/append-file
- cat $(1) >> $@
-endef
-
define Device/Default
PROFILES := Default
KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)