aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/brcm2708/Makefile8
-rw-r--r--target/linux/brcm2708/image/Makefile6
2 files changed, 9 insertions, 5 deletions
diff --git a/target/linux/brcm2708/Makefile b/target/linux/brcm2708/Makefile
index 8dc923907d..244513dfc6 100644
--- a/target/linux/brcm2708/Makefile
+++ b/target/linux/brcm2708/Makefile
@@ -1,5 +1,6 @@
#
# Copyright (C) 2012-2016 OpenWrt.org
+# Copyright (C) 2017 LEDE project
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -21,7 +22,12 @@ define Target/Description
endef
include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835 kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
+DEFAULT_PACKAGES += \
+ brcm2708-gpu-fw \
+ kmod-usb-hid \
+ kmod-sound-core kmod-sound-arm-bcm2835 \
+ kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
+ brcmfmac-firmware-43430-sdio kmod-brcmfmac wpad-mini
KERNELNAME:=Image dtbs
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 0b3f6a7588..7909c6d814 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -55,8 +55,8 @@ define Device/Default
endef
define Device/rpi
- DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero
- DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm
+ DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero/ZeroW
+ DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm bcm2708-rpi-0-w
endef
ifeq ($(SUBTARGET),bcm2708)
TARGET_DEVICES += rpi
@@ -65,7 +65,6 @@ endif
define Device/rpi-2
DEVICE_TITLE := Raspberry Pi 2B/3B/3CM
DEVICE_DTS := bcm2709-rpi-2-b bcm2710-rpi-3-b bcm2710-rpi-cm3
- DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio kmod-brcmfmac wpad-mini
endef
ifeq ($(SUBTARGET),bcm2709)
TARGET_DEVICES += rpi-2
@@ -75,7 +74,6 @@ define Device/rpi-3
KERNEL_IMG := kernel8.img
DEVICE_TITLE := Raspberry Pi 3B (64 bit)
DEVICE_DTS := broadcom/bcm2710-rpi-3-b
- DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio kmod-brcmfmac wpad-mini
endef
ifeq ($(SUBTARGET),bcm2710)
TARGET_DEVICES += rpi-3