aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/imx6/Makefile2
-rw-r--r--target/linux/imx6/config-3.104
-rw-r--r--target/linux/imx6/config-3.123
3 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/imx6/Makefile b/target/linux/imx6/Makefile
index 794a709b77..ac14eb21e4 100644
--- a/target/linux/imx6/Makefile
+++ b/target/linux/imx6/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=imx6
BOARDNAME:=Freescale i.MX 6 Series
-FEATURES:=audio display gpio pcie usb usbgadget squashfs targz ubifs
+FEATURES:=audio display gpio pcie rtc usb usbgadget squashfs targz ubifs
CPU_TYPE:=cortex-a9
CPU_SUBTYPE:=vfpv3
MAINTAINER:=Luka Perkov <luka@openwrt.org>
diff --git a/target/linux/imx6/config-3.10 b/target/linux/imx6/config-3.10
index 82346c919a..3dad5b67e5 100644
--- a/target/linux/imx6/config-3.10
+++ b/target/linux/imx6/config-3.10
@@ -306,6 +306,10 @@ CONFIG_REGULATOR_PFUZE100=y
# CONFIG_RFKILL_REGULATOR is not set
CONFIG_RFS_ACCEL=y
CONFIG_RPS=y
+CONFIG_RTC_CLASS=y
+# CONFIG_RTC_DRV_CMOS is not set
+# CONFIG_RTC_DRV_IMXDI is not set
+# CONFIG_RTC_DRV_MXC is not set
# CONFIG_SAMSUNG_USB2PHY is not set
# CONFIG_SAMSUNG_USB3PHY is not set
# CONFIG_SAMSUNG_USBPHY is not set
diff --git a/target/linux/imx6/config-3.12 b/target/linux/imx6/config-3.12
index 5ec8eddbd0..445a0cad43 100644
--- a/target/linux/imx6/config-3.12
+++ b/target/linux/imx6/config-3.12
@@ -305,6 +305,9 @@ CONFIG_REGULATOR_PFUZE100=y
# CONFIG_RFKILL_REGULATOR is not set
CONFIG_RFS_ACCEL=y
CONFIG_RPS=y
+CONFIG_RTC_CLASS=y
+# CONFIG_RTC_DRV_IMXDI is not set
+# CONFIG_RTC_DRV_MXC is not set
CONFIG_SATA_AHCI_PLATFORM=y
CONFIG_SCHED_HRTICK=y
CONFIG_SCSI=y