aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/brcm47xx/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 0074cf3edd..1bf577e159 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -244,6 +244,11 @@ define Device/linksys-e3000-v1
endef
TARGET_DEVICES += linksys-e3000-v1
+# generic has Ethernet drivers as modules so overwrite standard image
+define Device/standard
+ DEVICE_TITLE := Image with LZMA loader and LZMA compressed kernel
+ DEVICE_PACKAGES := kmod-b44 kmod-bgmac kmod-tg3
+endef
TARGET_DEVICES += standard
endif