aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/uboot-envtools/files/ramips1
-rw-r--r--target/linux/ramips/dts/AC1200RM.dts7
-rw-r--r--target/linux/ramips/image/mt7620.mk2
3 files changed, 8 insertions, 2 deletions
diff --git a/package/boot/uboot-envtools/files/ramips b/package/boot/uboot-envtools/files/ramips
index 88f561b0f4..f992f41bc8 100644
--- a/package/boot/uboot-envtools/files/ramips
+++ b/package/boot/uboot-envtools/files/ramips
@@ -13,6 +13,7 @@ touch /etc/config/ubootenv
board=$(board_name)
case "$board" in
+alfa-network,ac1200rm|\
alfa-network,awusfree1)
ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x1000" "0x1000"
;;
diff --git a/target/linux/ramips/dts/AC1200RM.dts b/target/linux/ramips/dts/AC1200RM.dts
index 9305cb00e0..9bdbf5cadf 100644
--- a/target/linux/ramips/dts/AC1200RM.dts
+++ b/target/linux/ramips/dts/AC1200RM.dts
@@ -148,8 +148,13 @@
};
partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x1000>;
+ };
+
+ partition@031000 {
label = "config";
- reg = <0x30000 0x10000>;
+ reg = <0x31000 0xf000>;
read-only;
};
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index e0a47b7340..c12a915245 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -32,7 +32,7 @@ define Device/alfa-network_ac1200rm
DTS := AC1200RM
IMAGE_SIZE := 16064k
DEVICE_TITLE := ALFA Network AC1200RM
- DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci uboot-envtools
endef
TARGET_DEVICES += alfa-network_ac1200rm