aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/image-commands.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 28b39c310e..01040138a4 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -309,6 +309,12 @@ metadata_json = \
define Build/append-metadata
$(if $(SUPPORTED_DEVICES),-echo $(call metadata_json,$(SUPPORTED_DEVICES)) | fwtool -I - $@)
+ [ -s "$(BUILD_KEY)" -a -s "$(BUILD_KEY).ucert" ] && { \
+ cp "$(BUILD_KEY).ucert" "$@.ucert" ;\
+ usign -S -m "$@" -s "$(BUILD_KEY)" -x "$@.sig" ;\
+ ucert -A -c "$@.ucert" -x "$@.sig" ;\
+ fwtool -S "$@.ucert" "$@" ;\
+ }
endef
define Build/kernel2minor