aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/usb.mk31
-rw-r--r--target/linux/mpc85xx/Makefile2
2 files changed, 10 insertions, 23 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index f11758c662..e2fe06f977 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -385,7 +385,8 @@ define KernelPackage/usb2
CONFIG_USB_EHCI_MXC=y \
CONFIG_USB_OCTEON_EHCI=y \
CONFIG_USB_EHCI_HCD_ORION=y \
- CONFIG_USB_EHCI_HCD_AT91=y
+ CONFIG_USB_EHCI_HCD_AT91=y \
+ CONFIG_USB_EHCI_FSL
FILES:= \
$(LINUX_DIR)/drivers/usb/host/ehci-platform.ko
ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-orion.ko),)
@@ -394,7 +395,13 @@ define KernelPackage/usb2
ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-atmel.ko),)
FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-atmel.ko
endif
- AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion ehci-atmel,1)
+ ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-fsl.ko),)
+ FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-fsl.ko
+ endif
+ ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/fsl-mph-dr-of.ko),)
+ FILES+=$(LINUX_DIR)/drivers/usb/host/fsl-mph-dr-of.ko
+ endif
+ AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion ehci-atmel ehci-fsl fsl-mph-dr-of,1)
$(call AddDepends/usb)
endef
@@ -405,26 +412,6 @@ endef
$(eval $(call KernelPackage,usb2))
-define KernelPackage/usb2-fsl
- TITLE:=Support for Freescale USB2 controllers
- DEPENDS:=+kmod-usb-ehci @TARGET_mpc85xx
- KCONFIG:= \
- CONFIG_USB_EHCI_HCD_PPC_OF=y \
- CONFIG_USB_EHCI_FSL=y
- FILES:= \
- $(LINUX_DIR)/drivers/usb/host/ehci-fsl.ko \
- $(LINUX_DIR)/drivers/usb/host/fsl-mph-dr-of.ko
- AUTOLOAD:=$(call AutoLoad,42,ehci-fsl fsl-mph-dr-of,1)
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb2-fsl/description
- Kernel support for Freescale USB2 (EHCI) controllers
-endef
-
-$(eval $(call KernelPackage,usb2-fsl))
-
-
define KernelPackage/usb2-pci
TITLE:=Support for PCI USB2 controllers
DEPENDS:=@PCI_SUPPORT +kmod-usb2
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index 02fdc2f53d..e08b00ab8e 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -22,6 +22,6 @@ include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += \
kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
- kmod-leds-gpio swconfig kmod-ath9k wpad-basic kmod-usb2-fsl
+ kmod-leds-gpio swconfig kmod-ath9k wpad-basic kmod-usb2
$(eval $(call BuildTarget))