aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README2
-rw-r--r--include/prereq-build.mk15
2 files changed, 12 insertions, 5 deletions
diff --git a/README b/README
index 55ca92af65..c867c1fa4d 100644
--- a/README
+++ b/README
@@ -11,7 +11,7 @@ To build your own firmware you need a Linux, BSD or MacOSX system (case
sensitive filesystem required). Cygwin is unsupported because of the lack
of a case sensitive file system.
-You need gcc, binutils, bzip2, flex, python, perl, make, find, grep, diff,
+You need gcc, binutils, bzip2, flex, python3.5+, perl, make, find, grep, diff,
unzip, gawk, getopt, subversion, libz-dev and libc headers installed.
1. Run "./scripts/feeds update -a" to obtain all the latest package definitions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index f7da916f64..c52ca71908 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -141,10 +141,17 @@ $(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
$(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
perl --version | grep "perl.*v5"))
-$(eval $(call SetupHostCommand,python,Please install Python 2.x, \
- python2.7 -V 2>&1 | grep Python, \
- python2 -V 2>&1 | grep Python, \
- python -V 2>&1 | grep Python))
+$(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
+ python3.7 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
+ python3.6 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
+ python3.5 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
+ python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
+
+$(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
+ python3.7 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
+ python3.6 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
+ python3.5 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
+ python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))