aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/i2c.mk15
-rw-r--r--target/linux/mpc85xx/config-4.43
2 files changed, 3 insertions, 15 deletions
diff --git a/package/kernel/linux/modules/i2c.mk b/package/kernel/linux/modules/i2c.mk
index bfc1171a0c..4fbf416b3a 100644
--- a/package/kernel/linux/modules/i2c.mk
+++ b/package/kernel/linux/modules/i2c.mk
@@ -104,21 +104,6 @@ endef
$(eval $(call KernelPackage,i2c-gpio))
-I2C_MPC_MODULES:=\
- CONFIG_I2C_MPC:drivers/i2c/busses/i2c-mpc
-
-define KernelPackage/i2c-mpc
- $(call i2c_defaults,$(I2C_MPC_MODULES),59)
- TITLE:=MPC I2C accessors
- DEPENDS:=@TARGET_mpc52xx||TARGET_mpc83xx||TARGET_mpc85xx +kmod-i2c-core
-endef
-
-define KernelPackage/i2c-mpc/description
- Kernel module for Freescale MPC52xx MPC83xx MPC85xx I2C accessors
-endef
-
-$(eval $(call KernelPackage,i2c-mpc))
-
I2C_IBM_IIC_MODULES:=\
CONFIG_I2C_IBM_IIC:drivers/i2c/busses/i2c-ibm_iic
diff --git a/target/linux/mpc85xx/config-4.4 b/target/linux/mpc85xx/config-4.4
index 2f08e6db30..6564b5daf7 100644
--- a/target/linux/mpc85xx/config-4.4
+++ b/target/linux/mpc85xx/config-4.4
@@ -157,6 +157,9 @@ CONFIG_HZ=250
# CONFIG_HZ_100 is not set
CONFIG_HZ_250=y
CONFIG_HZ_PERIODIC=y
+CONFIG_I2C=y
+CONFIG_I2C_BOARDINFO=y
+CONFIG_I2C_MPC=y
CONFIG_INITRAMFS_SOURCE=""
CONFIG_IOMMU_HELPER=y
# CONFIG_IPIC is not set