aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/malta/image/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/target/linux/malta/image/Makefile b/target/linux/malta/image/Makefile
index 180e045ec7..31eb7ca0bb 100644
--- a/target/linux/malta/image/Makefile
+++ b/target/linux/malta/image/Makefile
@@ -7,10 +7,6 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-define get_kernel_entry
-0x$(shell $(TARGET_CROSS)nm $(1) 2>/dev/null | grep " kernel_entry" | cut -f1 -d ' ')
-endef
-
define CompressLzma
$(STAGING_DIR_HOST)/bin/lzma e $(1) -lc1 -lp2 -pb2 $(2)
endef
@@ -21,7 +17,7 @@ endef
define MkuImage
mkimage -A mips -O linux -T kernel -a 0x80100000 -C $(1) $(2) \
- -e $(call get_kernel_entry,$(KDIR)/vmlinux.debug) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -e 0x80100000 -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
-d $(3) $(4)
endef