aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/patches-4.4/201-extra_optimization.patch2
-rw-r--r--target/linux/layerscape/patches-4.4/9070-Revert-arm64-use-fixmap-region-for-permanent-FDT-map.patch2
3 files changed, 4 insertions, 4 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index ee95997d86..f68f2f3fa2 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -3,10 +3,10 @@
LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .43
-LINUX_VERSION-4.4 = .148
+LINUX_VERSION-4.4 = .150
LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
-LINUX_KERNEL_HASH-4.4.148 = 19b10f009bb497a7e36995cc58811494f1cb46ae6ed02cc6d08babc97fc4d983
+LINUX_KERNEL_HASH-4.4.150 = 0f49295082ccdeae54a18b12c0be0ec01d320b6e6d59bf138a5e117543c0aef5
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
diff --git a/target/linux/generic/patches-4.4/201-extra_optimization.patch b/target/linux/generic/patches-4.4/201-extra_optimization.patch
index 8fa26bcae4..f5f542e062 100644
--- a/target/linux/generic/patches-4.4/201-extra_optimization.patch
+++ b/target/linux/generic/patches-4.4/201-extra_optimization.patch
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
-@@ -627,12 +627,12 @@ KBUILD_CFLAGS += $(call cc-disable-warni
+@@ -628,12 +628,12 @@ KBUILD_CFLAGS += $(call cc-disable-warni
KBUILD_CFLAGS += $(call cc-disable-warning, attribute-alias)
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
diff --git a/target/linux/layerscape/patches-4.4/9070-Revert-arm64-use-fixmap-region-for-permanent-FDT-map.patch b/target/linux/layerscape/patches-4.4/9070-Revert-arm64-use-fixmap-region-for-permanent-FDT-map.patch
index 45d4a8b8c9..cc17aebbf4 100644
--- a/target/linux/layerscape/patches-4.4/9070-Revert-arm64-use-fixmap-region-for-permanent-FDT-map.patch
+++ b/target/linux/layerscape/patches-4.4/9070-Revert-arm64-use-fixmap-region-for-permanent-FDT-map.patch
@@ -303,5 +303,5 @@ Signed-off-by: Yutang Jiang <yutang.jiang@nxp.com>
-}
-
#ifdef CONFIG_HAVE_ARCH_HUGE_VMAP
- int pud_free_pmd_page(pud_t *pud)
+ int pud_free_pmd_page(pud_t *pud, unsigned long addr)
{