aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/crypto.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index c788ebb549..6e3f2cc1d2 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -558,7 +558,8 @@ define KernelPackage/crypto-sha256
DEPENDS:=+kmod-crypto-hash
KCONFIG:= \
CONFIG_CRYPTO_SHA256 \
- CONFIG_CRYPTO_SHA256_OCTEON
+ CONFIG_CRYPTO_SHA256_OCTEON \
+ CONFIG_CRYPTO_SHA256_SSSE3
FILES:=$(LINUX_DIR)/crypto/sha256_generic.ko
AUTOLOAD:=$(call AutoLoad,09,sha256_generic)
$(call AddDepends/crypto)
@@ -569,6 +570,11 @@ define KernelPackage/crypto-sha256/octeon
AUTOLOAD:=$(call AutoLoad,09,octeon-sha256)
endef
+define KernelPackage/crypto-sha256/x86/64
+ FILES+=$(LINUX_DIR)/arch/x86/crypto/sha256-ssse3.ko
+ AUTOLOAD:=$(call AutoLoad,09,sha256-ssse3)
+endef
+
$(eval $(call KernelPackage,crypto-sha256))