aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/other.mk20
-rw-r--r--target/linux/imx6/image/Makefile4
-rw-r--r--target/linux/imx6/profiles/100-generic.mk2
3 files changed, 3 insertions, 23 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 30d145d7f2..9821780641 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -890,26 +890,6 @@ endef
$(eval $(call KernelPackage,thermal))
-define KernelPackage/thermal-imx
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Temperature sensor driver for Freescale i.MX SoCs
- DEPENDS:=@TARGET_imx6 +kmod-thermal
- KCONFIG:= \
- CONFIG_IMX_THERMAL
- FILES:=$(LINUX_DIR)/drivers/thermal/imx_thermal.ko
- AUTOLOAD:=$(call AutoProbe,imx_thermal)
-endef
-
-define KernelPackage/thermal-imx/description
- Support for Temperature Monitor (TEMPMON) found on Freescale i.MX SoCs.
- It supports one critical trip point and one passive trip point. The
- cpufreq is used as the cooling device to throttle CPUs when the
- passive trip is crossed.
-endef
-
-$(eval $(call KernelPackage,thermal-imx))
-
-
define KernelPackage/gpio-beeper
SUBMENU:=$(OTHER_MENU)
TITLE:=GPIO beeper support
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 2e4763ea65..7407db8037 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -86,7 +86,7 @@ define Device/ventana
imx6q-gw551x \
imx6q-gw552x \
imx6q-gw553x
- DEVICE_PACKAGES := kmod-thermal-imx kmod-sky2 kmod-usb-chipidea-imx kmod-usb-mxs-phy \
+ DEVICE_PACKAGES := kmod-sky2 kmod-usb-chipidea-imx kmod-usb-mxs-phy \
kmod-sound-core kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
kmod-can kmod-can-flexcan kmod-can-raw \
kmod-hwmon-gsc \
@@ -116,7 +116,7 @@ endef
define Device/wandboard
DEVICE_TITLE := Wandboard Dual
DEVICE_DTS := imx6dl-wandboard
- DEVICE_PACKAGES := kmod-thermal-imx kmod-usb-chipidea-imx kmod-usb-mxs-phy
+ DEVICE_PACKAGES := kmod-usb-chipidea-imx kmod-usb-mxs-phy
endef
TARGET_DEVICES += \
diff --git a/target/linux/imx6/profiles/100-generic.mk b/target/linux/imx6/profiles/100-generic.mk
index d977f9ab77..9d981fdc02 100644
--- a/target/linux/imx6/profiles/100-generic.mk
+++ b/target/linux/imx6/profiles/100-generic.mk
@@ -9,7 +9,7 @@ define Profile/Generic
PRIORITY:=1
NAME:=Generic (default)
PACKAGES:= \
- kmod-thermal-imx kmod-usb-chipidea-imx kmod-usb-mxs-phy
+ kmod-usb-chipidea-imx kmod-usb-mxs-phy
endef
define Profile/Generic/Description