aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--openwrt/package/axtls/Makefile1
-rw-r--r--openwrt/package/axtls/patches/002-strip.patch12
2 files changed, 13 insertions, 0 deletions
diff --git a/openwrt/package/axtls/Makefile b/openwrt/package/axtls/Makefile
index 9027976108..c53c4e5aea 100644
--- a/openwrt/package/axtls/Makefile
+++ b/openwrt/package/axtls/Makefile
@@ -26,6 +26,7 @@ $(PKG_BUILD_DIR)/.configured:
$(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR) \
CC=$(TARGET_CC) \
+ STRIP=/bin/true \
OPT_CFLAGS="$(TARGET_CFLAGS)" OPT_LDFLAGS=""
touch $@
diff --git a/openwrt/package/axtls/patches/002-strip.patch b/openwrt/package/axtls/patches/002-strip.patch
new file mode 100644
index 0000000000..95570b697a
--- /dev/null
+++ b/openwrt/package/axtls/patches/002-strip.patch
@@ -0,0 +1,12 @@
+diff -ruN axTLS-0.95-old/httpd/Makefile axTLS-0.95-new/httpd/Makefile
+--- axTLS-0.95-old/httpd/Makefile 2006-02-28 02:50:28.000000000 +0100
++++ axTLS-0.95-new/httpd/Makefile 2006-05-18 22:24:02.000000000 +0200
+@@ -87,7 +87,7 @@
+ $(LD) $(LDFLAGS) -o $@ $(OBJ) $(LIBS)
+ ifndef CONFIG_DEBUG
+ ifndef CONFIG_PLATFORM_SOLARIS
+- strip --remove-section=.comment $(TARGET)
++ $(STRIP) --remove-section=.comment $(TARGET)
+ endif
+ endif
+ else # Win32