aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--toolchain/gcc/Config.in4
-rw-r--r--toolchain/gcc/Config.version7
-rw-r--r--toolchain/gcc/common.mk8
3 files changed, 0 insertions, 19 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index d8141815fb..0c55048f3f 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -15,10 +15,6 @@ choice
select GCC_VERSION_4_8_LINARO
bool "gcc 4.8.x with Linaro enhancements"
- config GCC_USE_VERSION_4_9_LINARO
- select GCC_VERSION_4_9_LINARO
- bool "gcc 4.9.x with Linaro enhancements"
-
endchoice
config GCC_USE_GRAPHITE
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index 56de0d7bd4..dc6b93bb5f 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -6,15 +6,11 @@ config GCC_VERSION_4_8_LINARO
default y if (!TOOLCHAINOPTS && !TARGET_octeon)
bool
-config GCC_VERSION_4_9_LINARO
- bool
-
config GCC_VERSION
string
default "4.6.3" if GCC_VERSION_4_6_3
default "4.6-linaro" if GCC_VERSION_4_6_LINARO
default "4.8-linaro" if GCC_VERSION_4_8_LINARO
- default "4.9-linaro" if GCC_VERSION_4_9_LINARO
default "4.6-linaro"
config GCC_VERSION_4_6
@@ -25,6 +21,3 @@ config GCC_VERSION_4_8
bool
default y if GCC_VERSION_4_8_LINARO
-config GCC_VERSION_4_9
- bool
- default y if GCC_VERSION_4_9_LINARO
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index d07f607c47..dece29cb51 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -41,14 +41,6 @@ ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
PKG_MD5SUM:=5ba2f3a449b1658ccc09d27cc7ab3c03
PKG_COMP:=xz
endif
- ifeq ($(CONFIG_GCC_VERSION),"4.9-linaro")
- LINARO_RELEASE:=15.03
- PKG_REV:=4.9-2015.03
- PKG_VERSION:=4.9.3
- PKG_VERSION_MAJOR:=4.9
- PKG_MD5SUM:=f9d256d120adfbb45dd3e2d22b70cba9
- PKG_COMP:=xz
- endif
ifneq ($(LINARO_RELEASE),)
PKG_SOURCE_URL:=http://releases.linaro.org/$(LINARO_RELEASE)/components/toolchain/gcc-linaro/$(PKG_VERSION_MAJOR)
else