aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/network/services/hostapd/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 2e8eae2069..80e00823fe 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -88,6 +88,7 @@ endif
ifdef CONFIG_USE_EGLIBC
TARGET_LDFLAGS += -lrt
+ TARGET_LDFLAGS_C += -lrt
endif
DRV_DEPENDS:=+PACKAGE_kmod-mac80211:libnl-tiny @(!TARGET_avr32||BROKEN)
@@ -267,7 +268,7 @@ define Build/RunMake
$(TARGET_CONFIGURE_OPTS) \
$(DRIVER_MAKEOPTS) \
LIBS="$(TARGET_LDFLAGS)" \
- LIBS_c="" \
+ LIBS_c="$(TARGET_LDFLAGS_C)" \
BCHECK= \
$(2)
endef