aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/modules/netdevices.mk14
-rw-r--r--target/linux/rdc/profiles/ar525w.mk2
2 files changed, 8 insertions, 8 deletions
diff --git a/package/kernel/modules/netdevices.mk b/package/kernel/modules/netdevices.mk
index 7b2c3eedd4..c3f8d1ff38 100644
--- a/package/kernel/modules/netdevices.mk
+++ b/package/kernel/modules/netdevices.mk
@@ -51,20 +51,20 @@ endef
$(eval $(call KernelPackage,mvswitch))
-define KernelPackage/switch-ip175c
+define KernelPackage/switch-ip17xx
SUBMENU:=$(NETWORK_DEVICES_MENU)
- TITLE:=IC+ IP175C/IP178C switch support
+ TITLE:=IC+ IP17XX switch support
DEPENDS:=+kmod-swconfig
- KCONFIG:=CONFIG_IP175C_PHY
- FILES:=$(LINUX_DIR)/drivers/net/phy/ip175c.ko
- AUTOLOAD:=$(call AutoLoad,42,ip175c)
+ KCONFIG:=CONFIG_IP17XX_PHY
+ FILES:=$(LINUX_DIR)/drivers/net/phy/ip17xx.ko
+ AUTOLOAD:=$(call AutoLoad,42,ip17xx)
endef
-define KernelPackage/switch-ip175c/description
+define KernelPackage/switch-ip17xx/description
IC+ IP175C/IP178C switch support
endef
-$(eval $(call KernelPackage,switch-ip175c))
+$(eval $(call KernelPackage,switch-ip17xx))
define KernelPackage/natsemi
SUBMENU:=$(NETWORK_DEVICES_MENU)
diff --git a/target/linux/rdc/profiles/ar525w.mk b/target/linux/rdc/profiles/ar525w.mk
index c0659df1d6..d38cb1f232 100644
--- a/target/linux/rdc/profiles/ar525w.mk
+++ b/target/linux/rdc/profiles/ar525w.mk
@@ -7,6 +7,6 @@
define Profile/ar525w
NAME:=Airlink AR525W
- PACKAGES:=kmod-rt61-pci kmod-switch-ip175c swconfig
+ PACKAGES:=kmod-rt61-pci kmod-switch-ip17xx swconfig
endef
$(eval $(call Profile,ar525w))