aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/system/ubox/Makefile2
-rw-r--r--package/system/ubox/patches/100-insmod-segfault.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index 471afd6dc0..2d7ed29741 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ubox
-PKG_VERSION:=2015-02-25
+PKG_VERSION:=2015-02-25.1
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
diff --git a/package/system/ubox/patches/100-insmod-segfault.patch b/package/system/ubox/patches/100-insmod-segfault.patch
new file mode 100644
index 0000000000..df010d1a66
--- /dev/null
+++ b/package/system/ubox/patches/100-insmod-segfault.patch
@@ -0,0 +1,12 @@
+--- a/kmodloader.c
++++ b/kmodloader.c
+@@ -605,6 +605,9 @@ static int main_insmod(int argc, char **
+ cur += sprintf(cur, "%s", argv[i]);
+ }
+
++ if (init_module_folders())
++ return -1;
++
+ if (get_module_path(argv[1])) {
+ name = argv[1];
+ } else if (!get_module_path(name)) {