aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/libs/openssl/Makefile2
-rw-r--r--package/libs/openssl/patches/220-fix-no-ec-build.patch14
2 files changed, 15 insertions, 1 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index 860395ed18..b5f5ad73f2 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openssl
PKG_VERSION:=1.0.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_USE_MIPS16:=0
PKG_BUILD_PARALLEL:=1
diff --git a/package/libs/openssl/patches/220-fix-no-ec-build.patch b/package/libs/openssl/patches/220-fix-no-ec-build.patch
new file mode 100644
index 0000000000..44ec50eae4
--- /dev/null
+++ b/package/libs/openssl/patches/220-fix-no-ec-build.patch
@@ -0,0 +1,14 @@
+--- a/ssl/t1_lib.c
++++ b/ssl/t1_lib.c
+@@ -113,9 +113,11 @@
+ #include <openssl/objects.h>
+ #include <openssl/evp.h>
+ #include <openssl/hmac.h>
++#ifndef OPENSSL_NO_EC
+ #ifdef OPENSSL_NO_EC2M
+ # include <openssl/ec.h>
+ #endif
++#endif
+ #include <openssl/ocsp.h>
+ #include <openssl/rand.h>
+ #include "ssl_locl.h"