aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/busybox/Makefile3
-rw-r--r--package/busybox/patches/340-lock_util.patch3
2 files changed, 4 insertions, 2 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 2688777c00..2927d70436 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -13,7 +13,8 @@ PKG_VERSION:=1.3.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.busybox.net/downloads
+PKG_SOURCE_URL:=http://www.busybox.net/downloads \
+ http://distfiles.gentoo.org/distfiles/
PKG_MD5SUM:=571531cfa83726947ccb566de017ad4f
PKG_CAT:=bzcat
diff --git a/package/busybox/patches/340-lock_util.patch b/package/busybox/patches/340-lock_util.patch
index f832df7d91..a92fa3e047 100644
--- a/package/busybox/patches/340-lock_util.patch
+++ b/package/busybox/patches/340-lock_util.patch
@@ -39,7 +39,7 @@ diff -ruN busybox-1.3.1-old/miscutils/Kbuild busybox-1.3.1/miscutils/Kbuild
diff -ruN busybox-1.3.1-old/miscutils/lock.c busybox-1.3.1/miscutils/lock.c
--- busybox-1.3.1-old/miscutils/lock.c 1970-01-01 01:00:00.000000000 +0100
+++ busybox-1.3.1/miscutils/lock.c 2006-12-28 03:11:36.000000000 +0100
-@@ -0,0 +1,135 @@
+@@ -0,0 +1,136 @@
+/*
+ * Copyright (C) 2006 Felix Fietkau <nbd@openwrt.org>
+ *
@@ -136,6 +136,7 @@ diff -ruN busybox-1.3.1-old/miscutils/lock.c busybox-1.3.1/miscutils/lock.c
+
+ return 0;
+ }
++ return 0;
+}
+
+#ifndef CONFIG_LOCK