aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/grub/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/grub/Makefile b/package/grub/Makefile
index 502035a1c5..ee527be13f 100644
--- a/package/grub/Makefile
+++ b/package/grub/Makefile
@@ -49,8 +49,8 @@ ifeq ($(HOST_OS),Darwin)
HOST_CFLAGS += $(call host-cc-option,-fnested-functions)
endif
-ifeq ($(HOST_ARCH),amd64)
- ifeq ($(HOST_OS),FreeBSD)
+ifeq ($(HOST_OS),FreeBSD)
+ ifeq ($(HOST_ARCH),amd64)
HOST_CFLAGS += $(call host-cc-option,-m32)
HOST_CFLAGS += $(call host-cc-option,-B/usr/lib32)
HOST_CFLAGS += $(call host-cc-option,-L/usr/lib32)