aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/ltq-dsl-app/Makefile2
-rw-r--r--package/ltq-dsl/Makefile4
-rw-r--r--package/ltq-tapidemo/Config.in2
-rw-r--r--package/uboot-lantiq/Makefile2
-rw-r--r--target/linux/lantiq/Makefile2
-rw-r--r--target/linux/lantiq/image/Makefile2
-rw-r--r--target/linux/lantiq/modules.mk2
7 files changed, 8 insertions, 8 deletions
diff --git a/package/ltq-dsl-app/Makefile b/package/ltq-dsl-app/Makefile
index 5be052f6e2..1b1aa369c8 100644
--- a/package/ltq-dsl-app/Makefile
+++ b/package/ltq-dsl-app/Makefile
@@ -23,7 +23,7 @@ define Package/ltq-dsl-app
CATEGORY:=Network
TITLE:=Lantiq DSL userland tool
URL:=http://www.lantiq.com/
- DEPENDS:=@TARGET_lantiq_xway +kmod-ltq-dsl +libpthread
+ DEPENDS:=@TARGET_lantiq_danube +kmod-ltq-dsl +libpthread
MAINTAINER:=John Crispin <blogic@openwrt.org>
endef
diff --git a/package/ltq-dsl/Makefile b/package/ltq-dsl/Makefile
index f62bfe8849..d645af7770 100644
--- a/package/ltq-dsl/Makefile
+++ b/package/ltq-dsl/Makefile
@@ -33,7 +33,7 @@ define KernelPackage/ltq-dsl
SUBMENU:=Network Devices
TITLE:=Lantiq dsl driver
URL:=http://www.lantiq.com/
- DEPENDS:=@TARGET_lantiq_xway +kmod-atm
+ DEPENDS:=@TARGET_lantiq_danube +kmod-atm
FILES:=$(PKG_BUILD_DIR)/src/mei/lantiq_mei.ko \
$(PKG_BUILD_DIR)/src/drv_dsl_cpe_api.ko \
$(PKG_BUILD_DIR)/src/mei/lantiq_atm.ko
@@ -47,7 +47,7 @@ define Package/kmod-ltq-dsl-firmware/default
SUBMENU:=Network Devices
TITLE:=Firmware
URL:=http://www.lantiq.com/
- DEPENDS:=@TARGET_lantiq_xway kmod-ltq-dsl
+ DEPENDS:=@TARGET_lantiq_danube kmod-ltq-dsl
MAINTAINER:=John Crispin <blogic@openwrt.org>
endef
diff --git a/package/ltq-tapidemo/Config.in b/package/ltq-tapidemo/Config.in
index 7bd0f5c351..a799eddd02 100644
--- a/package/ltq-tapidemo/Config.in
+++ b/package/ltq-tapidemo/Config.in
@@ -1,7 +1,7 @@
choice
prompt "board selection"
depends on PACKAGE_ltq-tapidemo
- default VOICE_CPE_TAPIDEMO_BOARD_EASY50712_V3 if TARGET_lantiq_xway
+ default VOICE_CPE_TAPIDEMO_BOARD_EASY50712_V3 if TARGET_lantiq_danube
default VOICE_CPE_TAPIDEMO_BOARD_EASY508xx if TARGET_lantiq_ar9
default VOICE_CPE_TAPIDEMO_BOARD_EASY80910 if TARGET_lantiq_vr9
help
diff --git a/package/uboot-lantiq/Makefile b/package/uboot-lantiq/Makefile
index 943132c60a..404b540b6d 100644
--- a/package/uboot-lantiq/Makefile
+++ b/package/uboot-lantiq/Makefile
@@ -29,7 +29,7 @@ endif
define Package/uboot-lantiq-template
SECTION:=boot
CATEGORY:=Boot Loaders
- DEPENDS:=@TARGET_lantiq
+ DEPENDS:=@TARGET_lantiq_danube
URL:=http://www.denx.de/wiki/U-Boot
VARIANT:=$(1)
TITLE:=$(1) ($(2))
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index b9c228359f..82e5c3926a 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=lantiq
BOARDNAME:=Lantiq GPON/XWAY
FEATURES:=squashfs jffs2
-DEFAULT_SUBTARGET:=xway
+DEFAULT_SUBTARGET:=danube
LINUX_VERSION:=2.6.39.2
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 43ad0e88f3..f0c06fd94e 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -55,7 +55,7 @@ define Image/BuildKernel/Template
$(CP) $(KDIR)/uImage-$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-uImage
endef
-ifeq ($(CONFIG_TARGET_lantiq_xway),y)
+ifeq ($(CONFIG_TARGET_lantiq_danube),y)
define Image/BuildKernel/Profile/EASY50712
$(call Image/BuildKernel/Template,EASY50712,$(xway_cmdline))
endef
diff --git a/target/linux/lantiq/modules.mk b/target/linux/lantiq/modules.mk
index a4a96400d0..0d4ad2da1c 100644
--- a/target/linux/lantiq/modules.mk
+++ b/target/linux/lantiq/modules.mk
@@ -29,7 +29,7 @@ USB_MENU:=USB Support
define KernelPackage/usb-dwc-otg
TITLE:=Synopsis DWC_OTG support
SUBMENU:=$(USB_MENU)
- DEPENDS+=@TARGET_lantiq_xway +kmod-usb-core
+ DEPENDS+=@TARGET_lantiq_danube +kmod-usb-core
KCONFIG:=CONFIG_DWC_OTG \
CONFIG_DWC_OTG_DEBUG=n \
CONFIG_DWC_OTG_LANTIQ=y \