aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/modules/fs.mk4
-rw-r--r--target/linux/generic/config-2.6.321
-rw-r--r--target/linux/generic/config-2.6.332
-rw-r--r--target/linux/generic/config-2.6.342
-rw-r--r--target/linux/generic/config-2.6.352
-rw-r--r--target/linux/generic/config-2.6.362
-rw-r--r--target/linux/generic/config-2.6.372
7 files changed, 8 insertions, 7 deletions
diff --git a/package/kernel/modules/fs.mk b/package/kernel/modules/fs.mk
index e5714aab64..6f3248a2ab 100644
--- a/package/kernel/modules/fs.mk
+++ b/package/kernel/modules/fs.mk
@@ -76,7 +76,7 @@ define KernelPackage/fs-ext2
SUBMENU:=$(FS_MENU)
TITLE:=EXT2 filesystem support
KCONFIG:=CONFIG_EXT2_FS
- DEPENDS:=$(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache)
+ DEPENDS:=$(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache) +LINUX_2_6_30||LINUX_2_6_31
FILES:=$(LINUX_DIR)/fs/ext2/ext2.ko
AUTOLOAD:=$(call AutoLoad,32,ext2,1)
endef
@@ -94,7 +94,7 @@ define KernelPackage/fs-ext3
KCONFIG:= \
CONFIG_EXT3_FS \
CONFIG_JBD
- DEPENDS:=$(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache)
+ DEPENDS:=$(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache) +LINUX_2_6_30||LINUX_2_6_31
FILES:= \
$(LINUX_DIR)/fs/ext3/ext3.ko \
$(LINUX_DIR)/fs/jbd/jbd.ko
diff --git a/target/linux/generic/config-2.6.32 b/target/linux/generic/config-2.6.32
index 72ae4854f5..da93d605da 100644
--- a/target/linux/generic/config-2.6.32
+++ b/target/linux/generic/config-2.6.32
@@ -552,6 +552,7 @@ CONFIG_EXPERIMENTAL=y
# CONFIG_EXT4_DEBUG is not set
# CONFIG_EXT4_FS is not set
# CONFIG_EXT4_FS_XATTR is not set
+CONFIG_EXT4_USE_FOR_EXT23=y
CONFIG_EXTRA_FIRMWARE=""
CONFIG_EXTRA_TARGETS=""
# CONFIG_EZX_PCAP is not set
diff --git a/target/linux/generic/config-2.6.33 b/target/linux/generic/config-2.6.33
index 10d2af79ac..f51a31e6c6 100644
--- a/target/linux/generic/config-2.6.33
+++ b/target/linux/generic/config-2.6.33
@@ -561,7 +561,7 @@ CONFIG_EXPERIMENTAL=y
# CONFIG_EXT4DEV_FS is not set
# CONFIG_EXT4_DEBUG is not set
# CONFIG_EXT4_FS is not set
-# CONFIG_EXT4_USE_FOR_EXT23 is not set
+CONFIG_EXT4_USE_FOR_EXT23=y
CONFIG_EXTRA_FIRMWARE=""
CONFIG_EXTRA_TARGETS=""
# CONFIG_EZX_PCAP is not set
diff --git a/target/linux/generic/config-2.6.34 b/target/linux/generic/config-2.6.34
index bde140f99c..b77594a7e0 100644
--- a/target/linux/generic/config-2.6.34
+++ b/target/linux/generic/config-2.6.34
@@ -568,7 +568,7 @@ CONFIG_EXPERIMENTAL=y
# CONFIG_EXT4DEV_FS is not set
# CONFIG_EXT4_DEBUG is not set
# CONFIG_EXT4_FS is not set
-# CONFIG_EXT4_USE_FOR_EXT23 is not set
+CONFIG_EXT4_USE_FOR_EXT23=y
CONFIG_EXTRA_FIRMWARE=""
CONFIG_EXTRA_TARGETS=""
# CONFIG_EZX_PCAP is not set
diff --git a/target/linux/generic/config-2.6.35 b/target/linux/generic/config-2.6.35
index f1911ed3dd..09b0322521 100644
--- a/target/linux/generic/config-2.6.35
+++ b/target/linux/generic/config-2.6.35
@@ -593,7 +593,7 @@ CONFIG_EXPERIMENTAL=y
# CONFIG_EXT4DEV_FS is not set
# CONFIG_EXT4_DEBUG is not set
# CONFIG_EXT4_FS is not set
-# CONFIG_EXT4_USE_FOR_EXT23 is not set
+CONFIG_EXT4_USE_FOR_EXT23=y
CONFIG_EXTRA_FIRMWARE=""
CONFIG_EXTRA_TARGETS=""
# CONFIG_EZX_PCAP is not set
diff --git a/target/linux/generic/config-2.6.36 b/target/linux/generic/config-2.6.36
index 91248ecab9..a44364e09c 100644
--- a/target/linux/generic/config-2.6.36
+++ b/target/linux/generic/config-2.6.36
@@ -565,7 +565,7 @@ CONFIG_EXPERIMENTAL=y
# CONFIG_EXT4_DEBUG is not set
# CONFIG_EXT4_FS is not set
# CONFIG_EXT4_FS_XATTR is not set
-# CONFIG_EXT4_USE_FOR_EXT23 is not set
+CONFIG_EXT4_USE_FOR_EXT23=y
CONFIG_EXTRA_FIRMWARE=""
CONFIG_EXTRA_TARGETS=""
# CONFIG_EZX_PCAP is not set
diff --git a/target/linux/generic/config-2.6.37 b/target/linux/generic/config-2.6.37
index c44f0ff14a..c206eac3f9 100644
--- a/target/linux/generic/config-2.6.37
+++ b/target/linux/generic/config-2.6.37
@@ -563,7 +563,7 @@ CONFIG_EXPERIMENTAL=y
# CONFIG_EXT3_FS_XATTR is not set
# CONFIG_EXT4_DEBUG is not set
# CONFIG_EXT4_FS is not set
-# CONFIG_EXT4_USE_FOR_EXT23 is not set
+CONFIG_EXT4_USE_FOR_EXT23=y
CONFIG_EXTRA_FIRMWARE=""
CONFIG_EXTRA_TARGETS=""
# CONFIG_EZX_PCAP is not set