aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/hostapd/Makefile4
-rw-r--r--package/hostapd/files/wpa_supplicant.sh3
2 files changed, 5 insertions, 2 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 3b6b6feb3e..c4e5d9f25a 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
PKG_VERSION:=20111103
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_REV:=6caaae1e48da247b21b54ea6001646597e35d9b1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/hostapd/files/wpa_supplicant.sh b/package/hostapd/files/wpa_supplicant.sh
index 1ab6c663e5..9446202be3 100644
--- a/package/hostapd/files/wpa_supplicant.sh
+++ b/package/hostapd/files/wpa_supplicant.sh
@@ -87,9 +87,11 @@ wpa_supplicant_setup_vif() {
pairwise='pairwise=CCMP'
group='group=CCMP'
config_get identity "$vif" identity
+ config_get client_cert "$vif" client_cert
config_get priv_key "$vif" priv_key
config_get priv_key_pwd "$vif" priv_key_pwd
identity="identity=\"$identity\""
+ client_cert="client_cert=\"$client_cert\""
priv_key="private_key=\"$priv_key\""
priv_key_pwd="private_key_passwd=\"$priv_key_pwd\""
;;
@@ -132,6 +134,7 @@ network={
$group
$eap_type
$ca_cert
+ $client_cert
$priv_key
$priv_key_pwd
$phase2