aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/ubus/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/ubus/Makefile b/package/ubus/Makefile
index 7d427edb52..c7c643a68c 100644
--- a/package/ubus/Makefile
+++ b/package/ubus/Makefile
@@ -63,7 +63,8 @@ define Package/ubus/install
endef
define Package/ubusd/install
- $(INSTALL_DIR) $(1)/sbin
+ $(INSTALL_DIR) $(1)/sbin $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/ubus.init $(1)/etc/init.d/ubus
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/ubusd $(1)/sbin/
endef