aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/6to4/Makefile4
-rwxr-xr-xpackage/6to4/files.old/6to4.sh4
-rwxr-xr-xpackage/6to4/files/6to4.sh6
3 files changed, 11 insertions, 3 deletions
diff --git a/package/6to4/Makefile b/package/6to4/Makefile
index 45639646cc..fc36d0f152 100644
--- a/package/6to4/Makefile
+++ b/package/6to4/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2010-2011 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6to4
-PKG_VERSION:=7
+PKG_VERSION:=8
PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/6to4/files.old/6to4.sh b/package/6to4/files.old/6to4.sh
index f7f48e5ba4..2329e0bd47 100755
--- a/package/6to4/files.old/6to4.sh
+++ b/package/6to4/files.old/6to4.sh
@@ -24,6 +24,10 @@ test_6to4_rfc1918()
[ $1 -eq 10 ] && return 0
[ $1 -eq 192 ] && [ $2 -eq 168 ] && return 0
[ $1 -eq 172 ] && [ $2 -ge 16 ] && [ $2 -le 31 ] && return 0
+
+ # RFC 6598
+ [ $1 -eq 100 ] && [ $2 -ge 64 ] && [ $2 -le 127 ] && return 0
+
return 1
}
diff --git a/package/6to4/files/6to4.sh b/package/6to4/files/6to4.sh
index 6825385648..5cbdce79ab 100755
--- a/package/6to4/files/6to4.sh
+++ b/package/6to4/files/6to4.sh
@@ -31,6 +31,10 @@ test_6to4_rfc1918()
[ $1 -eq 10 ] && return 0
[ $1 -eq 192 ] && [ $2 -eq 168 ] && return 0
[ $1 -eq 172 ] && [ $2 -ge 16 ] && [ $2 -le 31 ] && return 0
+
+ # RFC 6598
+ [ $1 -eq 100 ] && [ $2 -ge 64 ] && [ $2 -le 127 ] && return 0
+
return 1
}
@@ -221,7 +225,7 @@ proto_6to4_teardown() {
}
proto_6to4_init_config() {
- no_device=1
+ no_device=1
available=1
proto_config_add_string "ipaddr"