aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/qos-scripts/Makefile2
-rwxr-xr-xpackage/qos-scripts/files/usr/lib/qos.sh1
2 files changed, 2 insertions, 1 deletions
diff --git a/package/qos-scripts/Makefile b/package/qos-scripts/Makefile
index 86eb6b3a23..bb5a9639f1 100644
--- a/package/qos-scripts/Makefile
+++ b/package/qos-scripts/Makefile
@@ -9,7 +9,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=qos-scripts
-PKG_VERSION:=0.9.3
+PKG_VERSION:=0.9.4
PKG_RELEASE:=1
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
diff --git a/package/qos-scripts/files/usr/lib/qos.sh b/package/qos-scripts/files/usr/lib/qos.sh
index 8fcf9dc27f..724784ebd0 100755
--- a/package/qos-scripts/files/usr/lib/qos.sh
+++ b/package/qos-scripts/files/usr/lib/qos.sh
@@ -275,6 +275,7 @@ BEGIN {
print "sfq perturb 10 limit " cqlen
} else {
avpkt = 1200
+ if (min < avpkt) min = avpkt
min = int(limit * 1024 / 8 * 0.1)
dqb = cqlen * 1500
max = int(min + (dqb - min) * 0.25)