aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/iproute2/Makefile5
-rw-r--r--package/iptables/Makefile34
-rw-r--r--package/mtd/Makefile2
-rw-r--r--package/nvram/Makefile11
4 files changed, 28 insertions, 24 deletions
diff --git a/package/iproute2/Makefile b/package/iproute2/Makefile
index 11336948f4..1fa638d39d 100644
--- a/package/iproute2/Makefile
+++ b/package/iproute2/Makefile
@@ -53,6 +53,5 @@ define Package/tc/install
install -m0755 $(PKG_BUILD_DIR)/tc/tc $(1)/usr/sbin/
endef
-# $(eval $(call BuildPackage,iproute2))
-# $(eval $(call BuildPackage,ip))
-# $(eval $(call BuildPackage,tc))
+$(eval $(call BuildPackage,ip))
+$(eval $(call BuildPackage,tc))
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index ae2adcfa08..4c547be998 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -162,6 +162,22 @@ define Build/Compile
DESTDIR="$(PKG_INSTALL_DIR)" \
all install install-devel
endef
+
+
+define Build/InstallDev
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
+ CC=$(TARGET_CC) COPT_FLAGS="$(TARGET_CFLAGS)" \
+ KERNEL_DIR=$(LINUX_DIR) PREFIX=/usr \
+ DESTDIR="$(STAGING_DIR)" \
+ install install-devel
+endef
+
+define Build/UninstallDev
+ rm -rf $(STAGING_DIR)/usr/include/libipq.h
+ rm -rf $(STAGING_DIR)/usr/lib/libipq.a
+endef
+
define Package/iptables/install
install -d -m0755 $(1)/etc/config
@@ -223,21 +239,3 @@ $(eval $(call BuildPlugin,iptables-mod-ipsec,$(IPT_IPSEC-m)))
$(eval $(call BuildPlugin,iptables-mod-nat,$(IPT_NAT-m)))
$(eval $(call BuildPlugin,iptables-mod-ulog,$(IPT_ULOG-m)))
$(eval $(call BuildPackage,ip6tables))
-
-
-$(STAGING_DIR)/usr/lib/libipq.a: $(PKG_BUILD_DIR)/.built
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- CC=$(TARGET_CC) COPT_FLAGS="$(TARGET_CFLAGS)" \
- KERNEL_DIR=$(LINUX_DIR) PREFIX=/usr \
- DESTDIR="$(STAGING_DIR)" \
- install install-devel
-
-install-dev: $(STAGING_DIR)/usr/lib/libipq.a
-uninstall-dev:
- rm -rf $(STAGING_DIR)/usr/include/libipq.h
- rm -rf $(STAGING_DIR)/usr/lib/libipq.a
-
-compile-targets: install-dev
-clean-targets: uninstall-dev
-
diff --git a/package/mtd/Makefile b/package/mtd/Makefile
index 0d684b8f49..fdb43eee15 100644
--- a/package/mtd/Makefile
+++ b/package/mtd/Makefile
@@ -26,3 +26,5 @@ define Package/mtd/install
install -d -m0755 $(1)/sbin
install -m0755 $(PKG_BUILD_DIR)/mtd $(1)/sbin
endef
+
+$(eval $(call BuildPackage,mtd))
diff --git a/package/nvram/Makefile b/package/nvram/Makefile
index 9cc6b9997a..5900f6f05b 100644
--- a/package/nvram/Makefile
+++ b/package/nvram/Makefile
@@ -28,9 +28,14 @@ define Package/nvram/install
install -m0755 $(PKG_BUILD_DIR)/nvram $(1)/usr/sbin
endef
-compile-targets: install-dev
-install-dev: $(PKG_BUILD_DIR)/.built
+define Build/InstallDev
mkdir -p $(STAGING_DIR)/usr/lib
$(CP) $(PKG_BUILD_DIR)/*.so $(STAGING_DIR)/usr/lib
-
+endef
+
+define Build/UninstallDev
+ rm -f $(STAGING_DIR)/usr/lib/libshared*.so \
+ $(STAGING_DIR)/usr/lib/libnvram*.so
+endef
+$(eval $(call BuildPackage,nvram))