aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2021-11-01 07:59:21 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2021-11-06 14:22:26 +0100
commite37dffbf3583e8f18ae197daba662ca157d99062 (patch)
tree0bcec0a5338e72b193b1a3b6fe3ca79e03cb849e /tools
parent15e55a2190ba087679b24b8844a51a6e4d512cf3 (diff)
downloadupstream-e37dffbf3583e8f18ae197daba662ca157d99062.tar.gz
upstream-e37dffbf3583e8f18ae197daba662ca157d99062.tar.bz2
upstream-e37dffbf3583e8f18ae197daba662ca157d99062.zip
tools/mkimage: pass --static via PKG_CONFIG_EXTRAARGS
Remove the then unnecessary patch doing exactly that individually. See also 09465d80 "u-boot.mk: always link host libraries static". Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'tools')
-rw-r--r--tools/mkimage/Makefile1
-rw-r--r--tools/mkimage/patches/210-link-libcrypto-static.patch14
2 files changed, 1 insertions, 14 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index 6901d921cf..1eb713a22a 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -32,6 +32,7 @@ define Host/Compile
$(MAKE) -C $(HOST_BUILD_DIR) \
HOSTCFLAGS="$(HOST_CFLAGS)" \
HOSTLDFLAGS="$(HOST_LDFLAGS)" \
+ PKG_CONFIG_EXTRAARGS="--static" \
no-dot-config-targets=tools-only \
CONFIG_MKIMAGE_DTC_PATH=dtc \
CONFIG_FIT=y \
diff --git a/tools/mkimage/patches/210-link-libcrypto-static.patch b/tools/mkimage/patches/210-link-libcrypto-static.patch
deleted file mode 100644
index 87a425bd94..0000000000
--- a/tools/mkimage/patches/210-link-libcrypto-static.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-OpenWrt links the libressl statically against mkimage, make sure all the
-needed dependencies are added too.
-
---- a/tools/Makefile
-+++ b/tools/Makefile
-@@ -158,7 +158,7 @@ ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CON
- HOSTCFLAGS_kwbimage.o += \
- $(shell pkg-config --cflags libssl libcrypto 2> /dev/null || echo "")
- HOSTLDLIBS_mkimage += \
-- $(shell pkg-config --libs libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
-+ $(shell pkg-config --libs --static libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
-
- # OS X deprecate openssl in favour of CommonCrypto, supress deprecation
- # warnings on those systems