aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2022-06-29 23:48:47 -0400
committerMichael Pratt <mcpratt@pm.me>2022-09-19 17:30:16 -0400
commit1e726ba015ce729cfe84e68e7924ed2258901cab (patch)
treefd598cb34c7c787528c5f250669ea3a46202d929 /tools
parent027845b4ce906a7819e12f6298b96dba0cb4a183 (diff)
downloadupstream-1e726ba015ce729cfe84e68e7924ed2258901cab.tar.gz
upstream-1e726ba015ce729cfe84e68e7924ed2258901cab.tar.bz2
upstream-1e726ba015ce729cfe84e68e7924ed2258901cab.zip
tools/cmake: fix download url with make variables
Use a make variable pattern for the url so that only one version number needs to be changed when version is bumped. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'tools')
-rw-r--r--tools/cmake/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index 9650755ba0..a0695c7d62 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -8,12 +8,13 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=cmake
PKG_VERSION:=3.24.1
+PKG_VERSION_MAJOR:=$(word 1,$(subst ., ,$(PKG_VERSION))).$(word 2,$(subst ., ,$(PKG_VERSION)))
PKG_RELEASE:=1
PKG_CPE_ID:=cpe:/a:kitware:cmake
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/Kitware/CMake/releases/download/v$(PKG_VERSION)/ \
- https://cmake.org/files/v3.24/
+ https://cmake.org/files/v$(PKG_VERSION_MAJOR)/
PKG_HASH:=4931e277a4db1a805f13baa7013a7757a0cbfe5b7932882925c7061d9d1fa82b
HOST_BUILD_PARALLEL:=1